New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Build against .NET 4.5.2 #175

Closed
kamsar opened this Issue Sep 21, 2016 · 2 comments

Comments

Projects
None yet
1 participant
@kamsar
Copy link
Collaborator

kamsar commented Sep 21, 2016

The next version of Unicorn will be compiled against .NET 4.5.2 like Sitecore 8.2 is. This does not affect backwards compatibility other than that the project Unicorn is bundled into must also be 4.5.2 or later target framework. So that will be an upgrade step. Sitecore 7.0+ has no problem with 4.5.2 assemblies.

As well, investigate referencing Sitecore from the public NuGet feed. We don't want to depend on it in the release mode (not everyone will be using it, and older Sitecore versions would get hosed), but would make dev setup handy.

@kamsar

This comment has been minimized.

Copy link
Collaborator

kamsar commented Sep 22, 2016

References updated in 4305f18 and surrounding commits. Build is now against 4.5.2 with the public NuGet feed enabled. lib/sitecore is no longer required 💯

@kamsar

This comment has been minimized.

Copy link
Collaborator

kamsar commented Oct 27, 2016

Released in 3.3.1

@kamsar kamsar closed this Oct 27, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment