New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error with Image.Load #178

Closed
KANekT opened this Issue Apr 17, 2017 · 3 comments

Comments

Projects
None yet
4 participants
@KANekT
Copy link

KANekT commented Apr 17, 2017

Prerequisites

  • I have written a descriptive issue title
  • I have verified that I am running the latest version of ImageSharp
  • I have searched open and closed issues to ensure it has not already been reported
  • I have verified if the problem exist in both DEBUG and RELEASE mode

Description

Steps to Reproduce

var image = Image.Load(file.OpenReadStream());

I have error Too many coefficients 64 > 63 for file/link

at ImageSharp.Formats.Jpg.JpegScanDecoder.Refine(InputProcessor& bp, HuffmanTree& h, Int32 delta) at ImageSharp.Formats.Jpg.JpegScanDecoder.DecodeBlock(JpegDecoderCore decoder, Int32 scanIndex) at ImageSharp.Formats.Jpg.JpegScanDecoder.DecodeBlocks(JpegDecoderCore decoder) at ImageSharp.Formats.JpegDecoderCore.ProcessStartOfScan(Int32 remaining) at ImageSharp.Formats.JpegDecoderCore.ProcessStream(ImageMetaData metadata, Stream stream, Boolean metadataOnly) at ImageSharp.Formats.JpegDecoderCore.Decode[TColor](Stream stream) at ImageSharp.Formats.JpegDecoder.Decode[TColor](Configuration configuration, Stream stream, IDecoderOptions options) at ImageSharp.Image.Decode[TColor](Stream stream, IDecoderOptions options, Configuration config) at ImageSharp.Image.Load[TColor](Configuration config, Stream stream, IDecoderOptions options) at ImageSharp.Image.Load(Stream stream) at Biggab.Game.Education.Backend.ViewModels.Words.CreateOrEditViewModelFactory.<SaveFile>d__5.MoveNext() in C:\Projects\BiggabSocial\src\Biggab.Game.Education.Backend\Areas\Backend\ViewModels\Words\CreateOrEditViewModelFactory.cs:line 99

System Configuration

  • ImageSharp version: 1.0.0-alpha9-00025
  • Other ImageSharp packages and versions:
  • Environment (Operating system, version and so on): Windows 10 VS 2015
  • .NET Framework version: 1.2
  • Additional information:
@tocsoft

This comment has been minimized.

Copy link
Member

tocsoft commented Apr 17, 2017

Look like it's an image specific issue, Please provide a copy of the image that causes this issue.

@antonfirsov

This comment has been minimized.

Copy link
Member

antonfirsov commented Apr 17, 2017

@tocsoft he has a link in the issue description :)

@tocsoft

This comment has been minimized.

Copy link
Member

tocsoft commented Apr 17, 2017

My bad, failed to spot the link.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment