Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

加载库报错 #10

Closed
liang979zhang opened this issue May 30, 2019 · 13 comments

Comments

@liang979zhang
Copy link

@liang979zhang liang979zhang commented May 30, 2019

image

@Sky24n

This comment has been minimized.

Copy link
Owner

@Sky24n Sky24n commented May 30, 2019

我是基于beta分支开发的,当前最新v1.5.4-hotfix.2。
dev分支上最新1.6.3,这个版本的方法有变化导致不兼容。
我这边只有等beta分支升级后再修改。因为这个是最稳定的版本。

flutter channel beta

@Sky24n

This comment has been minimized.

Copy link
Owner

@Sky24n Sky24n commented Jun 1, 2019

已修复。
flustars: ^0.2.5+1

@didiaogithub

This comment has been minimized.

Copy link

@didiaogithub didiaogithub commented Jun 2, 2019

屏幕快照 2019-06-02 下午5 09 27

@zhanghuibiao

This comment has been minimized.

Copy link

@zhanghuibiao zhanghuibiao commented Jun 3, 2019

同上
image

@Sky24n

This comment has been minimized.

Copy link
Owner

@Sky24n Sky24n commented Jun 3, 2019

flutter beta分支v1.5.4-hotfix.2,请用0.2.5版本。
flutter beta分支v1.6.3,请用0.2.5+1版本。

@Sky24n

This comment has been minimized.

Copy link
Owner

@Sky24n Sky24n commented Jun 14, 2019

flutter 1.6.3版本开始,这个方法就改变了导致的不兼容。升级到 1.6.3版本后就没有问题了。我是基于这个版本开发的。

[√] Flutter (Channel beta, v1.6.3, on Microsoft Windows [Version 10.0.17763.503], locale zh-CN)

这是最新的源码。
class ImageStreamListener {
  /// Creates a new [ImageStreamListener].
  ///
  /// The [onImage] parameter must not be null.
  const ImageStreamListener(
    this.onImage, {
    this.onChunk,
    this.onError,
  }) : assert(onImage != null);
@certhon

This comment has been minimized.

Copy link

@certhon certhon commented Jul 1, 2019

弱弱问一句 这个版本号在哪里改 yaml这个文件里好像没有看到这个widetutil

@Sky24n

This comment has been minimized.

Copy link
Owner

@Sky24n Sky24n commented Jul 1, 2019

弱弱问一句 这个版本号在哪里改 yaml这个文件里好像没有看到这个widetutil

dependencies:
flustars: ^0.2.6+1

@Sky24n Sky24n closed this Jul 9, 2019
@Kevin088

This comment has been minimized.

Copy link

@Kevin088 Kevin088 commented Jul 31, 2019

flustars: ^0.2.6+1 版本
widget_util.dart:88:26: Error: Method not found: 'ImageStreamListener'. 还是报这个错

@Sky24n

This comment has been minimized.

Copy link
Owner

@Sky24n Sky24n commented Jul 31, 2019

flustars: ^0.2.6+1 版本
widget_util.dart:88:26: Error: Method not found: 'ImageStreamListener'. 还是报这个错

上面说得那么清楚,还来问题!!!

@Kevin088

This comment has been minimized.

Copy link

@Kevin088 Kevin088 commented Jul 31, 2019

这个版本 flustars: ^0.2.6+1 不是修复了这个问题吗 可是我还是出这个错 运行不起来

@Sky24n

This comment has been minimized.

Copy link
Owner

@Sky24n Sky24n commented Jul 31, 2019

跟库没有任何关系,你flutter版本太低了,flutter 1.6.3版本开始,google官方改变的ImageStreamListener方法引起的不兼容,升级一下就好了!flutter upgrade
上面不是说的很清楚嘛!而且readme注意事项也有说明。

@Kevin088

This comment has been minimized.

Copy link

@Kevin088 Kevin088 commented Jul 31, 2019

好的 没看明白 不好意思

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
6 participants
You can’t perform that action at this time.