Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Updating r18n to 1.0.1.

Backstory: for some weird reason bundles would enforce version 1.0.1 on me. Had to change localization.rb to make it work.
  • Loading branch information...
commit 59776e1e0314c35769f39f76bc56850ceaee3784 1 parent cf07371
@Slotos authored
Showing with 5 additions and 6 deletions.
  1. +4 −4 Gemfile.lock
  2. +1 −2  lib/casserver/localization.rb
View
8 Gemfile.lock
@@ -1,7 +1,7 @@
PATH
remote: .
specs:
- rubycas-server (1.1.0)
+ rubycas-server (1.1.1)
activerecord (>= 2.3.12, < 3.1)
activesupport (>= 2.3.12, < 3.1)
crypt-isaac (~> 0.9.1)
@@ -46,7 +46,7 @@ GEM
multi_json (1.3.2)
net-ldap (0.1.1)
nokogiri (1.5.2)
- r18n-core (0.4.14)
+ r18n-core (1.0.1)
rack (1.4.1)
rack-protection (1.2.0)
rack
@@ -72,8 +72,8 @@ GEM
rack (~> 1.3, >= 1.3.6)
rack-protection (~> 1.2)
tilt (~> 1.3, >= 1.3.3)
- sinatra-r18n (0.4.14)
- r18n-core (= 0.4.14)
+ sinatra-r18n (1.0.1)
+ r18n-core (= 1.0.1)
sinatra (>= 1.3)
sqlite3 (1.3.6)
tilt (1.3.3)
View
3  lib/casserver/localization.rb
@@ -5,8 +5,7 @@ module Localization
def self.included(mod)
mod.module_eval do
register Sinatra::R18n
- set :default_locale, 'en'
- set :translations, File.dirname(__FILE__) + "/../../locales"
+ ::R18n.default_places { File.dirname( File.dirname self.root ) + "/locales" }
end
end
end
Please sign in to comment.
Something went wrong with that request. Please try again.