Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

vimproc_linux64.so is not found #544

Closed
in-in opened this issue May 18, 2017 · 6 comments
Milestone

Comments

@in-in
Copy link

@in-in in-in commented May 18, 2017

Expected behavior, english is recommend

No errors

Environment Information

  • OS: Linux Mint 18.1 Cinnamon 64-bit
  • neovim version: 0.1.7

The reproduce ways from Vim starting (Required!)

run nvim

Output of the ':SPDebugInfo!'

clipboard: provider is not available

please post log below, if you want me reproduce your issue quickly, post your custom config here will be better.

Screenshots

7b26f

If you have any screenshots for this issue please upload here. BTW you can use https://asciinema.org/ for recording video in terminal.

@wsdjeg

This comment has been minimized.

Copy link
Member

@wsdjeg wsdjeg commented May 18, 2017

you need compile vimproc. please read the doc of vimproc

@in-in

This comment has been minimized.

Copy link
Author

@in-in in-in commented May 18, 2017

I'm read it.
This :call dein#add('Shougo/vimproc.vim', {'build' : 'make'}) don't work. Nothing happens

@Shougo

This comment has been minimized.

Copy link

@Shougo Shougo commented May 19, 2017

I think your compiler configuration is broken.
You should execute make in vimproc directory.

I have read the same problem in SpaceVim gitter room.

src/proc.c:10:19: fatal error: stdio.h: No such file or directory
let me find article on setup for building from source... brb...
oh
ok, seems to have worked!
thanks Shougo!
Installing all build from source packages g++ etc, will take a while. Thanks for helping.
@Shougo

This comment has been minimized.

Copy link

@Shougo Shougo commented May 19, 2017

Note: He also uses Mint.

@in-in

This comment has been minimized.

Copy link
Author

@in-in in-in commented May 19, 2017

I installed build-essential before SpaceVim and problem were gone

@in-in in-in closed this May 19, 2017
@wsdjeg wsdjeg modified the milestone: v0.3.0 May 25, 2017
@shuntaka9576 shuntaka9576 mentioned this issue Feb 10, 2019
5 of 13 tasks complete
@ZihengJiang

This comment has been minimized.

Copy link

@ZihengJiang ZihengJiang commented Oct 16, 2019

Same issue again on OSX 10.15 Catalina. I think it is because this problem: https://stackoverflow.com/questions/58278260/cant-compile-a-c-program-on-a-mac-after-upgrading-to-catalina-10-15

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
4 participants
You can’t perform that action at this time.