New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Enable deoplete in vim8 && lsp support #994

Merged
merged 3 commits into from Nov 13, 2017

Conversation

Projects
None yet
2 participants
@wsdjeg
Member

wsdjeg commented Nov 12, 2017

These plugins will be added:

roxma/vim-hug-neovim-rpc
roxma/nvim-yarp
autozimu/LanguageClient-neovim

Before this PR is merged, we just use forked repo, and fix some issues, send PR to the origin repo.

error:

ImportError: /home/wsdjeg/.local/lib/python3.6/site-packages/greenlet.cpython-36m-x86_64-linux-gnu.so: undefined symbol: PyExc_ValueError

fixed by:

pip2 uninstall --user greenlet
pip3 uninstall --user greenlet
sudo pacman -S python-greenlet python2-greenlet

@wafflebot wafflebot bot added the WIP label Nov 12, 2017

@codecov

This comment has been minimized.

Show comment
Hide comment
@codecov

codecov bot Nov 12, 2017

Codecov Report

Merging #994 into dev will decrease coverage by 0.12%.
The diff coverage is 22.22%.

@@            Coverage Diff             @@
##              dev     #994      +/-   ##
==========================================
- Coverage   33.75%   33.62%   -0.13%     
==========================================
  Files         218      218              
  Lines        9252     9293      +41     
==========================================
+ Hits         3123     3125       +2     
- Misses       6129     6168      +39

codecov bot commented Nov 12, 2017

Codecov Report

Merging #994 into dev will decrease coverage by 0.12%.
The diff coverage is 22.22%.

@@            Coverage Diff             @@
##              dev     #994      +/-   ##
==========================================
- Coverage   33.75%   33.62%   -0.13%     
==========================================
  Files         218      218              
  Lines        9252     9293      +41     
==========================================
+ Hits         3123     3125       +2     
- Misses       6129     6168      +39

@SpaceVimBot SpaceVimBot referenced this pull request Nov 12, 2017

Closed

Get errors in vim8 #14

@wsdjeg wsdjeg merged commit 65f66e2 into dev Nov 13, 2017

4 of 7 checks passed

continuous-integration/travis-ci/pr The Travis CI build could not complete due to an error
Details
codecov/patch 22.22% of diff hit (target 33.75%)
Details
codecov/project 33.62% (-0.13%) compared to b90b27a
Details
continuous-integration/appveyor/branch AppVeyor build succeeded
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details
license/cla Contributor License Agreement is signed.
Details

@wafflebot wafflebot bot removed the WIP label Nov 13, 2017

@Halo9Pan

This comment has been minimized.

Show comment
Hide comment
@Halo9Pan

Halo9Pan Nov 20, 2017

This will make spacevim using 'deoplete' without neovim.

Halo9Pan commented on autoload/SpaceVim.vim in 62d5897 Nov 20, 2017

This will make spacevim using 'deoplete' without neovim.

This comment has been minimized.

Show comment
Hide comment
@wsdjeg

wsdjeg Nov 20, 2017

Member

deoplete supports both neovim and vim. but it need +python3 support.

Member

wsdjeg replied Nov 20, 2017

deoplete supports both neovim and vim. but it need +python3 support.

@wsdjeg wsdjeg deleted the lsp branch Nov 27, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment