Permalink
Browse files

Merge branch 'development'

  • Loading branch information...
mjy committed Nov 8, 2018
2 parents 71d5c9c + ec5c582 commit 50d43d8bfc12a027447f08b3146ad1bae241c829
Showing 430 changed files with 13,961 additions and 14,172 deletions.
@@ -9,7 +9,7 @@ cache:
dist: trusty
# sudo: required
rvm:
- 2.4.4
- 2.5.1
bundler_args: --without development production
branches:
only:
@@ -33,14 +33,18 @@ addons:
env:
global:
- PGPORT=5433
# - TEST_GROUP=1
# - TEST_GROUP=2
# - TEST_GROUP=3
# - TEST_GROUP=4
services:
- postgresql
before_install:
- nvm install node
- curl -o- -L https://yarnpkg.com/install.sh | bash -s -- --version 1.7.0
- export PATH=$HOME/.yarn/bin:$PATH
install:
- yarn
- npm install
- bundle install --without development production
before_script:
- "export DISPLAY=:99.0"
@@ -56,6 +60,7 @@ before_script:
- ls -alh public/packs-test
script:
- bundle exec rake assets:precompile
# - bundle exec parallel_test spec/ -n 6 --only-group $TEST_GROUP --group-by filesize --type rspec
- bundle exec rspec
notifications:
email:
@@ -1,6 +1,6 @@
FROM phusion/passenger-ruby24:0.9.31
FROM phusion/passenger-ruby25:0.9.35
MAINTAINER Matt Yoder
ENV LAST_FULL_REBUILD 2018-05-10
ENV LAST_FULL_REBUILD 2018-08-10
# From Phusion
ENV HOME /root
@@ -1,6 +1,6 @@
FROM ubuntu:16.04
MAINTAINER Matt Yoder
ENV LAST_FULL_REBUILD 2017-05-18
ENV LAST_FULL_REBUILD 2018-10-05
RUN apt-get update && \
apt-get install -y curl software-properties-common apt-transport-https && \
@@ -12,6 +12,10 @@ RUN curl -sS https://dl.yarnpkg.com/debian/pubkey.gpg | apt-key add - && \
echo "deb https://dl.yarnpkg.com/debian/ stable main" | tee /etc/apt/sources.list.d/yarn.list
RUN curl -sL https://deb.nodesource.com/setup_10.x | bash -
RUN apt install wget
RUN echo 'deb http://apt.postgresql.org/pub/repos/apt/ xenial-pgdg main' >> /etc/apt/sources.list.d/pgdg.list
RUN wget --quiet -O - https://www.postgresql.org/media/keys/ACCC4CF8.asc | apt-key add -
RUN apt-get update && \
apt-get install -y locales \
postgresql-client-10 \
@@ -46,7 +50,7 @@ RUN echo 'export RBENV_ROOT=/usr/local/rbenv' >> /root/.bashrc \
ENV CONFIGURE_OPTS --disable-install-doc
ENV PATH /usr/local/rbenv/bin:/usr/local/rbenv/shims:$PATH
ENV RBENV_VERSION 2.4.4
ENV RBENV_VERSION 2.5.1
RUN eval "$(rbenv init -)"; rbenv install $RBENV_VERSION \
&& eval "$(rbenv init -)"; rbenv global $RBENV_VERSION \
30 Gemfile
@@ -2,11 +2,11 @@ source 'https://rubygems.org'
gem 'rack-cors', '~> 1.0.1', require: 'rack/cors'
ruby '2.4.4'
ruby '2.5.1'
gem 'rake', '~> 12.0'
gem 'rails', '~> 5.1.6'
gem 'pg', '~> 0.21.0' # 1.0 not compatible with 5.1.4
gem 'rails', '5.2.1'
gem 'pg', '~> 1.0' # 1.0 not compatible with 5.1.4
gem 'activerecord-postgis-adapter', '~> 5.2.1'
gem 'hiredis', '~> 0.6.1'
@@ -25,7 +25,7 @@ gem 'rmagick', '~> 2.16'
# Geo
gem 'ffi-geos', '~> 1.2.0'
# gem 'rgeo-shapefile', '~> 0.4.2' # deprecated? not compatible- perhaps only used in
gem 'rgeo', '~> 1.0.0'
gem 'rgeo', '~> 1.1.1'
gem 'rgeo-geojson', '~> 2.0.0'
gem 'rgeo-proj4'
gem 'postgresql_cursor', '~> 0.6.1'
@@ -40,13 +40,13 @@ gem 'exception_notification', '~> 4.2.1'
# Models
gem 'bcrypt', '~> 3.1.11'
gem 'closure_tree', '~> 6.6'
gem 'closure_tree', '~> 7.0'
gem 'delayed_job_active_record', '~> 4.1.3'
gem 'validates_timeliness', '~> 4.0.2'
gem 'paper_trail', '~> 8.1.2'
gem 'paper_trail', '~> 10.0.1'
gem 'acts_as_list', '~> 0.9.12'
gem 'modularity', '~> 2.0.1' # Used!?
gem 'paperclip', '~> 5.2'
gem 'paperclip', '~> 6.1.0'
gem 'paperclip-meta', '~> 3.0'
gem 'shortener', '~> 0.8.0'
@@ -79,13 +79,13 @@ gem 'groupdate', '~> 4.0.1'
gem 'dropzonejs-rails', '~> 0.8.1'
gem 'kaminari', '~> 1.1.1'
gem 'best_in_place', '~> 3.1.1'
gem 'sass-rails', '~> 5.0.7' # auto compresses CSS
gem 'redcarpet', '~> 3.4'
gem 'sassc-rails', '~> 1.3.0'
# "Bio" and SFG gems
gem 'taxonifi', '0.4.0'
gem 'sqed', '0.4.4'
gem 'dwc-archive', '~> 0.9.11'
gem 'dwc-archive', '~> 1.0.1'
gem 'biodiversity', '~> 3.5.0'
gem 'ruby-units', '~> 2.3.0', require: 'ruby_units/namespaced'
@@ -104,7 +104,7 @@ gem 'capistrano-npm', '~> 1.0.2'
group :test, :development do
gem 'faker', '~> 1.9.1'
gem 'rspec-rails', '~> 3.6'
gem 'rspec-activemodel-mocks', '~> 1.0.3'
gem 'rspec-activemodel-mocks', '~> 1.1.0'
# gem 'inch', '~> 0.7.1', require: false, # security issue
gem 'byebug', '~> 10.0', {}.merge(ENV['RM_INFO'] ? {require: false} : {})
gem 'factory_bot_rails', '~> 4.11.0'
@@ -113,16 +113,18 @@ group :test, :development do
gem 'prawn', '~> 2.2.2'
end
gem 'parallel_tests', group: [:development, :test]
group :development do
# gem 'tunemygc'
gem 'ruby-prof', '~> 0.17.0'
gem 'better_errors', '~> 2.3'
gem 'binding_of_caller'
gem 'spring-commands-rspec', '~> 1.0.4'
gem 'guard-rspec', '~> 4.7.3', require: false
gem 'parallel_tests', '~> 2.22.1', require: false
gem 'web-console', '~> 3.7.0'
gem 'rubocop', '~> 0.58.2'
gem 'rubocop', '~> 0.59.2'
gem 'rubocop-rspec'
gem 'brakeman', '~> 4.3.0', require: false
gem 'seedbank', git: 'https://github.com/james2m/seedbank'
@@ -134,8 +136,8 @@ end
group :test do
gem 'rspec', '~> 3.6'
gem 'coveralls', '~> 0.8.21', require: false
gem 'capybara', '~> 3.7.0'
gem 'coveralls', '~> 0.8.22', require: false
gem 'capybara', '~> 3.9.0'
gem 'timecop', '~> 0.9.1'
gem 'webmock', '~> 3.4.1'
gem 'vcr', '~> 4.0.0'
Oops, something went wrong.

0 comments on commit 50d43d8

Please sign in to comment.