Browse files

Fix student provisioning regression due to 2.0 API change.

  • Loading branch information...
1 parent 4954f5e commit fe35f9bb8ac83a601a4724a0d992e91fa7d8c03d Greg Mathis committed with Aug 18, 2011
Showing with 3 additions and 3 deletions.
  1. +3 −3 lib/panopto_data.php
View
6 lib/panopto_data.php
@@ -113,9 +113,9 @@ function get_provisioning_info()
}
}
- // moodle/course:view capability will include all users who can view the course.
- // Could also use moodle/legacy:student if this turns out to be more appropriate.
- $students = get_users_by_capability($course_context, 'moodle/course:view');
+ // Give all enrolled users at least student-level access. Instructors will be filtered out below.
+ // Use get_enrolled_users because, as of Moodle 2.0, capability moodle/course:view no longer corresponds to a participant list.
+ $students = get_enrolled_users($course_context);
if(!empty($students))
{

0 comments on commit fe35f9b

Please sign in to comment.