New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

remove deprecated upgrade script #1282

Merged
merged 1 commit into from Jan 8, 2019

Conversation

Projects
None yet
3 participants
@lifeforms
Copy link
Collaborator

lifeforms commented Jan 8, 2019

Our upgrade script did two things, both of which are now unsupported and broken:

  1. update local CRS sources via Git pull (we only recommend downloading CRS releases now)
  2. download GeoIP database (Maxmind no longer provides this legacy database)

For now we are not going to salvage the upgrade tool and will delete it.

@lifeforms lifeforms added this to the CRS v3.2.0 milestone Jan 8, 2019

@lifeforms lifeforms merged commit 505a66b into SpiderLabs:v3.2/dev Jan 8, 2019

1 check was pending

continuous-integration/travis-ci/pr The Travis CI build is in progress
Details
@artictriac

This comment has been minimized.

Copy link

artictriac commented on 88559a9 Jan 15, 2019

Is there a replacement upgrade script or equivalent? The current installation instructions still reference util/upgrade.py so if there is a newer script to use, I'm sorry but I'm missing it. Thanks.

This comment has been minimized.

Copy link
Collaborator

dune73 replied Jan 15, 2019

We're between major releases and we're going to update the documentation before the next release.
The current idea is to download / clone from github / website - or use the packages in your distribution.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment