Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix deprecated warnings with Ansible 2.7 #208

Merged
merged 4 commits into from Oct 22, 2018
Merged

Conversation

@arhue
Copy link
Contributor

@arhue arhue commented Oct 21, 2018

This PR fixes two issues:

  1. Referenced in issue: #203
  2. Use state=present instead of state=installed for apt/yum module.

Closes #203

armab
armab approved these changes Oct 22, 2018
Copy link
Member

@armab armab left a comment

Thanks for the contribution! 👍

I also picked up for this PR Ansible lint warning fixes from #209

Loading

@armab armab merged commit 7282c84 into StackStorm:master Oct 22, 2018
1 check passed
Loading
@arhue arhue deleted the fix-2.7-errors branch Oct 23, 2018
@arhue
Copy link
Contributor Author

@arhue arhue commented Oct 23, 2018

Thank you! :)

Loading

@arhue arhue restored the fix-2.7-errors branch Oct 23, 2018
@arhue
Copy link
Contributor Author

@arhue arhue commented Oct 23, 2018

@armab Someone told me here: angstwad/docker.ubuntu#223 that this could bump Ansible version to 2.3. I couldn't find anything in the docs to support this. Any idea if this is true? If so, I can create an another PR to bump the Ansible version.

Loading

@armab
Copy link
Member

@armab armab commented Oct 23, 2018

@arhue Great point RE minimum v2.3 support.
Yes, that would be absolutely welcome!

Loading

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked issues

Successfully merging this pull request may close these issues.

2 participants