Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

"path.exists is now called `fs.exists`." OK, got it.

This commit bumps the required Node.js version to >=0.8. As a result, we
need to take care of some deprecation warnings such as the one listed in
the subject of this commit.
  • Loading branch information...
commit 8a490776a21032d7eb710492f128c07ec04f0e5b 1 parent 1189ae6
Stan Angeloff authored
Showing with 5 additions and 4 deletions.
  1. +4 −3 bin/cli.js
  2. +1 −1  package.json
7 bin/cli.js
View
@@ -2,7 +2,8 @@
const PHANTOMJS_VERSION = '~1.3.0 || ~1.4.0 || ~1.5.0 || ~1.6.0';
-var path = require('path'),
+var fs = require('fs'),
+ path = require('path'),
optimist = require('optimist'),
console = require('../lib/console'),
events = require('../lib/events');
@@ -97,7 +98,7 @@ if (process.argv.indexOf('--') < 0 && defaults._.length) {
defaults.path = path.resolve(defaults.path || process.env['LOTTE_PATH'] || process.cwd());
var lotteFile = path.join(defaults.path, defaults.lottefile);
-path.exists(lotteFile, function(exists) {
+fs.exists(lotteFile, function(exists) {
if (exists) {
load(defaults, lotteFile, function(e, options) {
if (e) {
@@ -208,7 +209,7 @@ function verifyPhantomBinary(options, resume) {
function collect(options, resume) {
var absolute = path.resolve(options.path);
- path.exists(absolute, function(exists) {
+ fs.exists(absolute, function(exists) {
if ( ! exists) {
console.error("Could not resolve '%s'.", absolute);
process.exit(1 << 7);
2  package.json
View
@@ -27,7 +27,7 @@
"express": "~2.5.0"
},
"engines": {
- "node": ">=0.4.10"
+ "node": ">=0.8"
},
"preferGlobal": true
}
Please sign in to comment.
Something went wrong with that request. Please try again.