New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Wi-Fi] Problems when trying to connect to melonAP #257

Closed
SIGMA-AX opened this Issue Oct 18, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@SIGMA-AX

SIGMA-AX commented Oct 18, 2018

I've run into some pretty interesting problems in regards to trying to set-up Wi-Fi in a game's WFC. Before going into detail as to what the issues are, I am on Windows 7 x64 and:

  • I have already installed Winpcap, that initializes fine when I check the the command line log when melonDS is running.
  • My main connection is solely through ethernet, and the adapter which I am using (Realtek PCIe GBE Family Controller) has had its driver updated to the latest version.

So at first, I received this error when trying to connect to the AP instead of the usual 20100 error:

error 5200

I decided to do a little check on my network adapters and realized that I had a few of them on which served other purposes for other programs I suppose:

adapters

So I decided to see whether melonDS doesn't detect my main connection (Local Area Connection 2) and decided to disable the other adapters to see what would happen. It results in this crash:

melonds wi-fi crash

@StapleButter

This comment has been minimized.

Owner

StapleButter commented Oct 23, 2018

@SIGMA-AX

This comment has been minimized.

SIGMA-AX commented Oct 24, 2018

I see, guess it's just something that will be worked much later down the line.

@SIGMA-AX SIGMA-AX closed this Oct 24, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment