New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Puzzler World 2 (USA) black screens #274

Closed
benderscruffy opened this Issue Nov 10, 2018 · 3 comments

Comments

Projects
None yet
2 participants
@benderscruffy
Copy link

benderscruffy commented Nov 10, 2018

after the loading screen nothing but black screens and music playing in the background

@StapleButter

This comment has been minimized.

Copy link
Owner

StapleButter commented Dec 13, 2018

the game seems to even react to input (playing sounds when I click the touchscreens)

it's just not displaying shit for some reason

it's also a regression, it works fine in 0.2 but starts breaking in 0.3

@StapleButter

This comment has been minimized.

Copy link
Owner

StapleButter commented Dec 13, 2018

there's something acting up with depth test

it's using equal-mode depth test, and hacking that to always pass makes the graphics show up

noting that the clear Z is set to 0x7FFF (expanded to 0xFFFFFF), nothing unusual there

@StapleButter

This comment has been minimized.

Copy link
Owner

StapleButter commented Dec 13, 2018

as a side note: the game uses 'equal' depth test and gives all its polygons Z=1.0

which is why nothing was showing up

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment