Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MacOS robo3t app crashes after I open up the edit window #1581

Closed
sakalys opened this Issue Sep 9, 2018 · 10 comments

Comments

2 participants
@sakalys
Copy link

sakalys commented Sep 9, 2018

Robo 3T 1.2.1
MacOS

A window with results (big collection) from a regex (unindexed) search was open. The crash happens after one enters the edit window of a document from that result set.

By the way, the results are displayed from a remote server which is accessed over an SSH tunnel.

@sakalys

This comment has been minimized.

Copy link
Author

sakalys commented Sep 9, 2018

Correction:
I think the crash happens after I hit Save (Or any other crud operation) which triggers a result set refresh.

So to recap:

  1. load a slow result-set;
  2. Edit/delete a document for the set;
  3. During the loading (there is no indication for that), try to open up another document for editing.
@simsekgokhan

This comment has been minimized.

Copy link
Collaborator

simsekgokhan commented Jan 15, 2019

Hi @sakalys , thanks for reporting the problem.
Can you please try our beta? We have some related code changes which can fix your problem.

Robo 3T 1.3 Beta
https://github.com/Studio3T/robomongo/releases/tag/v1.3.0-beta

@sakalys

This comment has been minimized.

Copy link
Author

sakalys commented Jan 15, 2019

Still reproducable in beta

@sakalys

This comment has been minimized.

Copy link
Author

sakalys commented Jan 15, 2019

I'll upload a video shortly

@sakalys

This comment has been minimized.

Copy link
Author

sakalys commented Jan 15, 2019

@simsekgokhan

This comment has been minimized.

Copy link
Collaborator

simsekgokhan commented Jan 17, 2019

@sakalys Thanks a lot for the video, the problem is clear now. At first glance, seems like we need to disable editing and show progress bar while waiting for a doc edit operation to be finished.

@simsekgokhan simsekgokhan reopened this Jan 19, 2019

simsekgokhan added a commit that referenced this issue Jan 19, 2019

Attempt to fix #1581: For remove document(s) ops showing progress bar…
… and disabling context menu while waiting operation to finish
@simsekgokhan

This comment has been minimized.

Copy link
Collaborator

simsekgokhan commented Feb 17, 2019

@sakalys We have entered some changes, can you check please?
Feel free to open the ticket if you find problem again.

Robo 3T 1.3 Beta
https://github.com/Studio3T/robomongo/releases/tag/v1.3.0-beta

@sakalys

This comment has been minimized.

Copy link
Author

sakalys commented Feb 21, 2019

@sakalys

This comment has been minimized.

Copy link
Author

sakalys commented Feb 21, 2019

@simsekgokhan

This comment has been minimized.

Copy link
Collaborator

simsekgokhan commented Feb 21, 2019

@sakalys
Cool, thanks a lot for verifying. We tested but you never know, crashes are always hard problems ;)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.