Skip to content
SublimeLinter plugin for python, using pylint.
Branch: master
Clone or download
kaste Merge pull request #55 from SublimeLinter/kaste-patch-1
Use `$file_on_disk` to fix deprecation message
Latest commit c895790 Feb 21, 2019
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
.github add config for no-response-robot May 17, 2018
messages prep 1.5 May 24, 2018
.flake8
.gitignore Missing .gitignore, fix travis build. May 5, 2014
.travis.yml Proper travis and flake8 config Apr 24, 2018
LICENSE initial and functional version Dec 20, 2013
README.md
linter.py
messages.json

README.md

SublimeLinter-pylint

Build Status

This linter plugin for SublimeLinter provides an interface to pylint. It will be used with files that have the "python" syntax.

Installation

SublimeLinter must be installed in order to use this plugin.

Please use Package Control to install the linter plugin.

Before using this plugin, ensure that pylint (1.0 or later) is installed on your system. To install pylint, do the following:

  1. Install Python and pip. If you plan to code in Python 3, you will need to install pip for Python 3 as well.

  2. Install pylint by typing the following in a terminal, replacing ‘x’ with the minor version installed on your system:

    # For python 2.x
    [sudo] pip-2.x install pylint
    
    # For python 3.x
    [sudo] pip-3.x install pylint
    
    # On Windows, for python 2.x
    c:\Python2x\Scripts\pip.exe install pylint
    
    # On Windows, for python 3.x
    c:\Python3x\Scripts\pip.exe install pylint

Please make sure that the path to pylint is available to SublimeLinter. The docs cover troubleshooting PATH configuration.

Settings

Pylint can be configured using .pylintrc configuration files and inline comments, more information in the pylint docs.

You can’t perform that action at this time.