New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

3.5.6 startup error (on WinXP) #2799

Open
cliffshit opened this Issue Mar 2, 2018 · 9 comments

Comments

Projects
None yet
4 participants
@cliffshit

cliffshit commented Mar 2, 2018

Since 3.5.6 get an error every time when starting SE. Clicking 'cancel' crashes program, 'retry' or 'ignore' continue program as usual.

@cliffshit

This comment has been minimized.

cliffshit commented Mar 2, 2018

img_0073

@niksedk

This comment has been minimized.

Member

niksedk commented Mar 2, 2018

Sorry, many sites (like github) has upgraded their security to only allow TLS 1.2 and that's why download of plugins/mpv/tesseract-dictionaries does not work in SE 3.5.5 and earlier and that feature is not available in .net 4.0.

So, I can no longer make SE work completely in WinXP :(
But you can run older versions of SE or even latest beta of SE - just not with working download of plugins/mpv/tesseract-dictionaries
Latest beta: https://github.com/SubtitleEdit/subtitleedit/releases/download/3.5.6/SubtitleEditBeta.zip

@darnn

This comment has been minimized.

darnn commented Mar 2, 2018

btw, since you were asking for suggestions about the help file, maybe put links in there to manually download all this stuff for people who can't download them automatically?

@darnn

This comment has been minimized.

darnn commented Mar 2, 2018

Or maybe even custom error messages for every download function in SE that explain the problem and provide a link?

@niksedk niksedk changed the title from 3.5.6 startup error to 3.5.6 startup error (on WinXP) Mar 2, 2018

@cliffshit

This comment has been minimized.

cliffshit commented Mar 2, 2018

Thanks for help and beta :)

@niksedk

This comment has been minimized.

Member

niksedk commented Mar 2, 2018

Mpv can be found here: https://mpv.srsfckn.biz/ in the "Dev" package. Copy mpv-1.dll to the Subtitle Edit folder. I don't know if it works on WinXP though.

Plugins here: https://github.com/SubtitleEdit/plugins/releases/tag/v.1.1 (unpack to the "Plugins" folder)

Tesseract dictionaries here: https://github.com/SubtitleEdit/support-files/tree/master/tessdata (unpack to the "Tesseract/tessdata" folder)

And just in case, spell check dictionaries are here: https://github.com/LibreOffice/dictionaries (save dic/aff files to the "Dictionaries" folder)

@darnn

This comment has been minimized.

darnn commented Mar 2, 2018

The 64bit version of mpv-1.dll, if you're getting it from that archive, btw.

This was referenced Apr 1, 2018

@francwalter

This comment has been minimized.

francwalter commented Apr 30, 2018

Which is the last working version for Windows XP?

I tried 3.5.4 but also this throws errors or crashes when I use vlc (13 x "App interupted with ctrl+c" Error MessageBox) or mpv (NtCreateFile-API failed... "Message: MPV - not all needed methods found in dll file" ... ) or DirectShow (missing LAV decoders, not available for xp it seems).

Is there a older version working with VLC then on XP?
Thank

@darnn

This comment has been minimized.

darnn commented Nov 17, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment