Permalink
Browse files

Revert "Python 2.3 and 2.4 are no longer supported"

This reverts commit b96fc86.
  • Loading branch information...
1 parent b96fc86 commit 97bdfa8524f5bd1f7e6dae4429c0b6447fed7ca5 @mnaberez mnaberez committed Feb 16, 2013
Showing with 8 additions and 7 deletions.
  1. +1 −0 .travis.yml
  2. +5 −5 README.txt
  3. +2 −2 setup.py
View
1 .travis.yml
@@ -2,6 +2,7 @@
language: python
python:
+ - "2.4"
- "2.5"
- "2.6"
- "2.7"
View
10 README.txt
@@ -2,7 +2,7 @@ meld3
Overview
- meld3 is an HTML/XML templating system for Python 2.5+ which keeps
+ meld3 is an HTML/XML templating system for Python 2.3+ which keeps
template markup and dynamic rendering logic separate from one
another. See http://www.entrian.com/PyMeld for a treatise on the
benefits of this pattern.
@@ -17,7 +17,7 @@ Overview
Requirements
- Python 2.5+
+ Python 2.3+
ElementTree 1.2+ (http://effbot.org/downloads/#elementtree)
@@ -101,7 +101,7 @@ Examples
<head>
<meta content="text/html; charset=ISO-8859-1" http-equiv="content-type" />
<title meld:id="title">This is the title</title>
- </head>
+ </head>
<body>
<div/> <!-- empty tag -->
<div meld:id="content_well">
@@ -348,13 +348,13 @@ Element API
"__mod__(other)": Fill in the text values of meld nodes in this
element and children recursively; only support dictionarylike
"other" operand (sequence operand doesn't seem to make sense here).
-
+
"fillmelds(**kw)":Fill in the text values of meld nodes in this
element and children recursively. Return the names of keys in the
**kw dictionary that could not be found anywhere in the tree. Never
raise an exception.
- "write_xml(file, encoding=None, doctype=None, fragment=False,
+ "write_xml(file, encoding=None, doctype=None, fragment=False,
declaration=True, pipeline=False)":
Write XML to 'file' (which can be a filename or filelike object)
encoding -- encoding string (if None, 'utf-8' encoding is assumed)
View
4 setup.py
@@ -2,8 +2,8 @@
import os
import sys
-if sys.version_info[:2] < (2, 5) or sys.version_info[0] > 2:
- msg = ("meld3 requires Python 2.5 or later but does not work on any "
+if sys.version_info[:2] < (2, 3) or sys.version_info[0] > 2:
+ msg = ("meld3 requires Python 2.3 or later but does not work on any "
"version of Python 3. You are using version %s. Please "
"install using a supported version." % sys.version)
sys.stderr.write(msg)

0 comments on commit 97bdfa8

Please sign in to comment.