Permalink
Browse files

Python 2.4 is no longer supported

The minimum required version has been raised to 2.5, since that is the
current minimum version required by Supervisor.
  • Loading branch information...
1 parent 0bd2408 commit 52a5079eeaaee7e82ff9a07e044b8fc44a1d8d7d @mnaberez mnaberez committed Jan 18, 2013
Showing with 5 additions and 2 deletions.
  1. +3 −0 CHANGES.txt
  2. +2 −2 setup.py
View
@@ -3,6 +3,9 @@ Next Release
- Superlance will now refuse to install on an unsupported version of Python.
+- Python 2.4 is no longer supported. The last version that supported Python
+ 2.4 is Superlance 0.7.
+
0.7 (2012-08-22)
----------------
View
@@ -1,8 +1,8 @@
import os
import sys
-if sys.version_info[:2] < (2, 4) or sys.version_info[0] > 2:
- msg = ("Superlance requires Python 2.4 or later but does not work on "
+if sys.version_info[:2] < (2, 5) or sys.version_info[0] > 2:
+ msg = ("Superlance requires Python 2.5 or later but does not work on "
"any version of Python 3. You are using version %s. Please "
"install using a supported version." % sys.version)
sys.stderr.write(msg)

0 comments on commit 52a5079

Please sign in to comment.