Skip to content
Permalink
Branch: master
Find file Copy path
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
76 lines (75 sloc) 2.3 KB
{
"name": "@surabayajs/website",
"description": "Latest SurabayaJS website 🐊",
"version": "1.0.0",
"repository": "https://github.com/SurabayaJS/website.git",
"author": "Griko Nibras <grikomsn@gmail.com>",
"scripts": {
"develop": "gatsby develop",
"serve": "gatsby serve",
"ssr": "yarn build && yarn serve",
"format": "prettier --config ./.prettierrc --write src/**/*.js",
"build:dir": "mkdirp ./public/icons/",
"build:favicons": "node scripts/favicons",
"build": "yarn build:dir && yarn build:favicons && gatsby build",
"now-build": "yarn build",
"test": "ava **/*.test.js --verbose"
},
"greenkeeper": {
"ignore": [
"ava",
"core-js"
]
},
"dependencies": {
"@sindresorhus/class-names": "^1.0.0",
"babel-plugin-styled-components": "^1.10.0",
"bulma": "^0.7.4",
"emojione": "^4.5.0",
"gatsby": "^2.3.25",
"gatsby-image": "^2.0.39",
"gatsby-plugin-offline": "^2.0.25",
"gatsby-plugin-purgecss": "^3.1.1",
"gatsby-plugin-react-helmet": "^3.0.12",
"gatsby-plugin-react-svg": "^2.1.1",
"gatsby-plugin-sass": "^2.0.11",
"gatsby-plugin-sharp": "^2.0.35",
"gatsby-plugin-sitemap": "^2.0.12",
"gatsby-plugin-styled-components": "^3.0.7",
"gatsby-plugin-webpack-size": "^0.0.3",
"gatsby-source-filesystem": "^2.0.29",
"gatsby-transformer-json": "^2.1.11",
"gatsby-transformer-sharp": "^2.1.18",
"node-sass": "^4.11.0",
"prop-types": "^15.7.2",
"react": "^16.8.6",
"react-dom": "^16.8.6",
"react-helmet": "^5.2.0",
"react-pose": "^4.0.8",
"styled-components": "^4.2.0"
},
"devDependencies": {
"@types/react": "^16.8.14",
"@types/react-dom": "^16.8.4",
"ava": "^1.4.1",
"babel-eslint": "^10.0.1",
"chrome-launcher": "^0.10.5",
"core-js": "^2.6.5",
"directory-named-webpack-plugin": "^4.0.1",
"eslint": "^5.16.0",
"eslint-config-prettier": "^4.1.0",
"eslint-loader": "^2.1.2",
"eslint-plugin-import": "^2.17.2",
"eslint-plugin-jsx-a11y": "^6.2.1",
"eslint-plugin-prettier": "^3.0.1",
"eslint-plugin-react": "^7.12.4",
"favicons": "^5.3.0",
"gatsby-plugin-eslint": "^2.0.4",
"lighthouse": "^4.3.0",
"mkdirp": "^0.5.1",
"node-gyp": "^3.8.0",
"prettier": "^1.17.0"
},
"private": true,
"license": "MIT"
}
You can’t perform that action at this time.