Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Fetching contributors…

Cannot retrieve contributors at this time

101 lines (95 sloc) 3.993 kb
# Generated by jeweler
# DO NOT EDIT THIS FILE DIRECTLY
# Instead, edit Jeweler::Tasks in Rakefile, and run 'rake gemspec'
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = "barista"
s.version = "1.3.0"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Darcy Laycock"]
s.date = "2012-07-23"
s.description = "Barista provides simple, integrated support for CoffeeScript in Rack and Rails applications.\n\nMuch like Compass does for Sass, It also provides Frameworks (bundleable code which can be shared via Gems).\n\nLastly, it also provides a Rack Application (which can be used to server compiled code), a around_filter-style precompiler (as Rack middleware) and simple helpers for rails and Haml.\n\nFor more details, please see the the README file bundled with it."
s.email = "sutto@sutto.net"
s.extra_rdoc_files = [
"LICENSE",
"README.md"
]
s.files = [
".document",
".rspec",
".rvmrc.example",
"DESCRIPTION",
"Gemfile",
"Gemfile.lock",
"LICENSE",
"README.md",
"Rakefile",
"barista.gemspec",
"lib/barista.rb",
"lib/barista/capistrano.rb",
"lib/barista/compiler.rb",
"lib/barista/extensions.rb",
"lib/barista/filter.rb",
"lib/barista/framework.rb",
"lib/barista/haml_filter.rb",
"lib/barista/helpers.rb",
"lib/barista/hooks.rb",
"lib/barista/integration.rb",
"lib/barista/integration/rails2.rb",
"lib/barista/integration/rails3.rb",
"lib/barista/integration/sinatra.rb",
"lib/barista/rake_task.rb",
"lib/barista/server.rb",
"lib/barista/tasks.rb",
"lib/barista/tasks/barista.rake",
"lib/barista/version.rb",
"lib/generators/barista/install/USAGE",
"lib/generators/barista/install/install_generator.rb",
"lib/generators/barista/install/templates/initializer.rb",
"lib/generators/barista_install_generator.rb",
"spec/assets/alert.coffee",
"spec/barista_spec.rb",
"spec/spec_helper.rb"
]
s.homepage = "http://github.com/Sutto/barista"
s.require_paths = ["lib"]
s.rubygems_version = "1.8.24"
s.summary = "Simple, transparent coffeescript integration for Rails and Rack applications."
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<coffee-script>, ["~> 2.2"])
s.add_development_dependency(%q<rails>, ["~> 3.0"])
s.add_development_dependency(%q<jeweler>, ["~> 1.0"])
s.add_development_dependency(%q<rspec>, ["~> 2.6"])
s.add_development_dependency(%q<rspec-rails>, ["~> 2.6"])
s.add_development_dependency(%q<rspec-core>, ["~> 2.6"])
s.add_development_dependency(%q<rdoc>, ["~> 2.4"])
s.add_development_dependency(%q<rr>, ["~> 1.0"])
s.add_development_dependency(%q<ruby-debug>, [">= 0"])
s.add_development_dependency(%q<ruby-debug19>, ["~> 0.11"])
else
s.add_dependency(%q<coffee-script>, ["~> 2.2"])
s.add_dependency(%q<rails>, ["~> 3.0"])
s.add_dependency(%q<jeweler>, ["~> 1.0"])
s.add_dependency(%q<rspec>, ["~> 2.6"])
s.add_dependency(%q<rspec-rails>, ["~> 2.6"])
s.add_dependency(%q<rspec-core>, ["~> 2.6"])
s.add_dependency(%q<rdoc>, ["~> 2.4"])
s.add_dependency(%q<rr>, ["~> 1.0"])
s.add_dependency(%q<ruby-debug>, [">= 0"])
s.add_dependency(%q<ruby-debug19>, ["~> 0.11"])
end
else
s.add_dependency(%q<coffee-script>, ["~> 2.2"])
s.add_dependency(%q<rails>, ["~> 3.0"])
s.add_dependency(%q<jeweler>, ["~> 1.0"])
s.add_dependency(%q<rspec>, ["~> 2.6"])
s.add_dependency(%q<rspec-rails>, ["~> 2.6"])
s.add_dependency(%q<rspec-core>, ["~> 2.6"])
s.add_dependency(%q<rdoc>, ["~> 2.4"])
s.add_dependency(%q<rr>, ["~> 1.0"])
s.add_dependency(%q<ruby-debug>, [">= 0"])
s.add_dependency(%q<ruby-debug19>, ["~> 0.11"])
end
end
Jump to Line
Something went wrong with that request. Please try again.