Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Update gemsepc to work with Rails 3.1 #10

Closed
aaronchi opened this Issue May 5, 2011 · 7 comments

Comments

Projects
None yet
5 participants

aaronchi commented May 5, 2011

:)

jhender commented Sep 5, 2011

same issue here. can it be used with 3.1?
gemfile dependency doesn't allow at the moment

aaronchi commented Sep 5, 2011

you may want to look at friendly_id v4 beta. It's got most of the same functionality

jhender commented Sep 6, 2011

thanks aaronchi. i have already tried the other fork and seems to install fine

$ bundle install
Fetching source index for http://rubygems.org/
Bundler could not find compatible versions for gem "activerecord":
In Gemfile:
slugged (>= 0) ruby depends on
activerecord (~> 3.0.0) ruby

rails (= 3.1.3) ruby depends on
  activerecord (3.1.3)

Same problem with rails 3.2:

$ bundle
Fetching source index for https://rubygems.org/
Bundler could not find compatible versions for gem "activesupport":
In Gemfile:
slugged (>= 0) ruby depends on
activesupport (~> 3.0.0) ruby

rails (= 3.2.0) ruby depends on
  activesupport (3.2.0)

I ended up using https://github.com/norman/friendly_id instead.... Does the job just fine!

Owner

Sutto commented Apr 5, 2012

Hey guys, Sorry I'd left this so long - it's been fixed for a few weeks now, and I've just set it up with travis and release 1.1.0 which includes that and fixes for Rails 3.2.3.

Once again, apologies for the issues. Hopefully it should be better from now on.

@Sutto Sutto closed this Apr 5, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment