Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

TAStudio.OnQueryItemBg transparency color problem solved #1221

Closed
OrgThing opened this issue Jun 21, 2018 · 3 comments

Comments

Projects
None yet
4 participants
@OrgThing
Copy link

commented Jun 21, 2018

When you make script with passing integer value as color and this integer value contains transparency color above then 0x7F value, then ColorTranslator.FromHtml function returns wrong value and just you see it in this screenshot:
argb_problem
So I suggest to change this to:
50ticks_argb
Not only that solve this problem then do his job much more faster compered to this one:
150ticks_string

@NarryG

This comment has been minimized.

Copy link
Contributor

commented Jun 21, 2018

Just submit a pull request with the changes if you already have them made. Looking at the reference source, they used Convert.ToInt32 for some reason.

@Azreally

This comment has been minimized.

Copy link
Contributor

commented Jun 21, 2018

I will. I know this problem because I'm using this function to mark jumps. When you make function return integer like this (e. g.):

tastudio.onqueryitembg(
    function ( current_index, current_input )
        if ( current_input == "A" ) then
            return 0xCF1F2F3F;
        end;
    end ) );

Input color will gone! I'll fix this.

@Azreally

This comment has been minimized.

Copy link
Contributor

commented Jun 21, 2018

Done. #1222

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.