Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

wl18xx: allow ELP by default for PG2.0

This is supported by new FW versions (.96+).

Signed-off-by: Arik Nemtsov <arik@wizery.com>
Signed-off-by: Ido Reis <idor@ti.com>
  • Loading branch information...
commit df0d7364bcc2db6a5f1311583f67c36e1e4b5fe2 1 parent 515f44e
@idor idor authored
Showing with 1 addition and 2 deletions.
  1. +1 −2  drivers/net/wireless/ti/wl18xx/main.c
View
3  drivers/net/wireless/ti/wl18xx/main.c
@@ -633,8 +633,7 @@ static int wl18xx_identify_chip(struct wl1271 *wl)
wl->sr_fw_name = WL18XX_FW_PG2_NAME;
/* wl18xx uses the same firmware for PLT */
wl->plt_fw_name = WL18XX_FW_PG2_NAME;
- wl->quirks |= WLCORE_QUIRK_NO_ELP |
- WLCORE_QUIRK_RX_BLOCKSIZE_ALIGN;
+ wl->quirks |= WLCORE_QUIRK_RX_BLOCKSIZE_ALIGN;
if (enable_pad_last_frame) {
wl->quirks |= WLCORE_QUIRK_TX_PAD_LAST_FRAME;
wl->quirks &= ~WLCORE_QUIRK_TX_BLOCKSIZE_ALIGN;
Please sign in to comment.
Something went wrong with that request. Please try again.