Skip to content

XML External Entity in Dashboard Widget

low
ohader published GHSA-q9cp-mc96-m4w2 Nov 17, 2020

Package

composer typo3/cms-core (composer)

Affected versions

10.4.0-10.4.9

Patched versions

10.4.10

Description

Meta

  • CVSS: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:L/E:U/RL:O/RC:R (3.1)
  • CWE-611

Problem

It has been discovered that RSS widgets are susceptible to XML external entity processing.
This vulnerability is reasonable, but is theoretical - it was not possible to actually reproduce the vulnerability with current PHP versions of supported and maintained system distributions.

At least with libxml2 version 2.9, the processing of XML external entities is disabled per default - and cannot be exploited. Besides that, a valid backend user account is needed.

Solution

Update to TYPO3 version 10.4.10 that fixes the problem described.

Credits

Thanks to Victoria Lee who reported this issue and to TYPO3 security team member Oliver Hader who fixed the issue.

References

CVE ID

CVE-2020-26229