Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ULX Menu Commands Not Working #136

Open
FadeTheLil opened this issue Jul 22, 2018 · 17 comments
Open

ULX Menu Commands Not Working #136

FadeTheLil opened this issue Jul 22, 2018 · 17 comments
Assignees
Labels
bug

Comments

@FadeTheLil
Copy link

@FadeTheLil FadeTheLil commented Jul 22, 2018

Steps to reproduce

  1. install ULX
  2. Log into server
  3. Use menu commands

Expected behavior

Tell us what should happen

When I use the commands in the ULX Menu, they should work normally, example.
!jail should jail the player, and I should be able to do this from the menu, not using the !jail text command.

Actual behavior

Tell us what happens instead

When I try to use a command in the menu, I don't get an error, but the menu command doesn't work and all that it does is print the usage of the command in chat.
For example, I go to "Fun" and use a command,
instead of actually working, it just prints the usage and the command in chat. It never did this before.

Error(s) in server console, if any

[ERROR] addons/ulx/lua/ulx/xgui/server/sv_bans.lua:186: bad argument #1 to 'lower' (string expected, got nil)

  1. lower - [C]:-1
  2. unknown - addons/ulx/lua/ulx/xgui/server/sv_bans.lua:186
    3. unknown - addons/ulx/lua/ulx/modules/xgui_server.lua:72
    4. unknown - lua/includes/modules/concommand.lua:54

(even deleted this file "sv_bans.lua) and didnt get the error anymore, but the commands still didn't work, which leads me to think its an addon conflict

Error(s) in player's console, if any

None, nothing pops up here.

Version

Run "ulx version" in console and paste the result

ULib v2.63
ULX v3.73

(I've tried reinstalling as well, no luck)
(and I also 100% reintalled it, deleted data, etc)

@jellyton69
Copy link

@jellyton69 jellyton69 commented Sep 3, 2018

I have also recently begun encountering this issue, no idea what the issue is.

@Aholicknight
Copy link

@Aholicknight Aholicknight commented Sep 27, 2018

Have you tried a clean reinstall of ULX & ULib by deleting the data folders etc?

@mark27205
Copy link

@mark27205 mark27205 commented Jan 1, 2019

Have you tried a clean reinstall of ULX & ULib by deleting the data folders etc?

... He said it.

@jellyton69
Copy link

@jellyton69 jellyton69 commented Jan 8, 2019

Alright I fixed it a long time ago, it was an addon causing the issue

@Nayruden
Copy link
Member

@Nayruden Nayruden commented Jan 8, 2019

Which addon, @jellyton69?

@WilliamCTurner
Copy link

@WilliamCTurner WilliamCTurner commented Apr 15, 2019

I have been getting the same problem and I did do a fresh server reinstall and still won't work.

@Aholicknight
Copy link

@Aholicknight Aholicknight commented Apr 17, 2019

@jellyton69 If this issue is fixed can you close it? Thanks.

@SticklyMan SticklyMan self-assigned this Apr 17, 2019
@SticklyMan SticklyMan added the bug label Apr 17, 2019
@SticklyMan
Copy link
Contributor

@SticklyMan SticklyMan commented Apr 17, 2019

While the primary issue can be caused by other addons or bad data, XGUI should handle it gracefully. I'll see what I can do about working around it when I get a chance.

@WilliamCTurner
Copy link

@WilliamCTurner WilliamCTurner commented Apr 18, 2019

On my server I had to reinstall the whole server with new gmod server files and it still won’t work.

@WilliamCTurner
Copy link

@WilliamCTurner WilliamCTurner commented Apr 18, 2019

[ULX] lua/ulx/xgui/server/sv_bans.lua:186: bad argument #1 to 'lower' (string expected, got nil)

  1. lower - [C]:-1
  2. unknown - lua/ulx/xgui/server/sv_bans.lua:186
    3. unknown - lua/ulx/modules/xgui_server.lua:72
    4. unknown - lua/includes/modules/concommand.lua:54
@WilliamCTurner
Copy link

@WilliamCTurner WilliamCTurner commented Apr 18, 2019

Also when I try to use the menu for commands it only shows a usage in chat

@NubileEye
Copy link

@NubileEye NubileEye commented Jul 30, 2019

I am having the same issue on Enhanced Prop Hunt version K. I have installed, reinstalled, uninstalled many times and I am still unable to use the command "Mute" or "gimp". Muting does show command usage, but does not actually mute the player. Gimp doesn't replace their text under the predetermined array of text.

@NubileEye
Copy link

@NubileEye NubileEye commented Aug 21, 2019

I have managed to self RESOLVE my own issue. The issue was a shitty lua autorun I got from steam workshop: https://steamcommunity.com/sharedfiles/filedetails/?id=297111172 | After removing this addon from my server, it started working again. Sorry for causing a false alarm. ULX and Ulib are essential, fundamental programs that vastly improve the servers they are implemented on. Thank you so much.

@Aholicknight
Copy link

@Aholicknight Aholicknight commented Aug 26, 2019

@FadeTheLil is this issue resolved?

@aezlfzmd
Copy link

@aezlfzmd aezlfzmd commented Nov 16, 2020

Bonjour j'ai un probléme avec mes groupe un superadmin a enlever tout les perm dans les groupe si quelqu'un sais comment je pourrais rénisialiser le menu ulx merci de bien vouloir de me répondre. (désoler pour mes fautes)

@Aholicknight
Copy link

@Aholicknight Aholicknight commented Nov 16, 2020

English translation: Hello I have a problem with my groups a superadmin to remove all the perms in the groups if anyone knows how I could renisialize the ulx menu please answer me. (sorry for my mistakes)

@aezlfzmd
Copy link

@aezlfzmd aezlfzmd commented Nov 17, 2020

j'ai fait pas mal de d'erreur mais j'étais fatigué se soir la si vous avez si il y a une commande qui permet de renisialiser le menu ulx merci de bien vouloir me répondre

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
9 participants
You can’t perform that action at this time.