Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Upgrade PostgreSQL to version 11 #4642

Merged
merged 5 commits into from Apr 11, 2019

Conversation

Projects
None yet
3 participants
@zloster
Copy link
Contributor

commented Apr 11, 2019

This is adding PostgreSQL official APT repository.
Two important settings are introduced:

  • wal_level = minimal
  • max_wal_senders = 0

The run in TravisCI is showing Rust/actix, Rust/actix-diesel, Rust/actix-pg, Rust/actix-platform as failing due to this change. The build is taking too long and can't finish checking of the rest of the Rust frameworks. Maybe there will be other errors.

The other problems which seems not to be related are:

@zloster

This comment has been minimized.

Copy link
Contributor Author

commented Apr 11, 2019

The Rust frameworks are OK. So all seems to be good.

@nbrady-techempower nbrady-techempower merged commit c1c5d1c into TechEmpower:master Apr 11, 2019

1 check failed

continuous-integration/travis-ci/pr The Travis CI build failed
Details

@zloster zloster deleted the zloster:upgrade-postgresql branch Apr 12, 2019

daviddenton added a commit to http4k/FrameworkBenchmarks that referenced this pull request Jun 1, 2019

Upgrade PostgreSQL to version 11 (TechEmpower#4642)
* Activate PostgreSQL APT repository and make teh setting of WAL level=minimal explicit

* Fix key import

* Change PostgreSQL version in the variable

* Set max_wal_senders explicitly to 0

* Change hardcoded path locations from 9.5 to 11
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.