Telepathy GLib-based client library that uses Farstream to handle Call channels
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
doc
examples
m4
telepathy-farstream
tools
.gitignore
AUTHORS
COPYING
ChangeLog
Makefile.am
NEWS
README
autogen.sh
configure.ac

README

=======================
telepathy-farstream
=======================

Telepathy Farstream is a Telepathy client library that uses Farstream
to handle Call channels.

Telepathy is a D-Bus framework for unifying real time communication,
including instant messaging, voice calls and video calls. It abstracts
differences between protocols to provide a unified interface for
applications.

Requirements
============

telepathy-farstream requires:
  telepathy-glib <http://telepathy.freedesktop.org/releases/telepathy-glib/>
  Farstream <http://farsight.freedesktop.org/releases/farstream/>
  GStreamer base plugins <http://gstreamer.freedesktop.org/>
  GLib, GObject <http://ftp.gnome.org/pub/GNOME/sources/glib/>
  libdbus <http://dbus.freedesktop.org/releases/dbus/>
  The D-Bus GLib bindings <http://dbus.freedesktop.org/releases/dbus-glib/>

At build time, it also requires:
  GNU make <http://www.gnu.org/software/make/>
  pkg-config <http://ftp.gnome.org/pub/GNOME/sources/pkg-config/>
  libxslt, xsltproc <http://xmlsoft.org/XSLT/>
  Python <http://www.python.org/>

See configure.ac for full details, including versions required.

Building from Darcs also requires the GNU build system (Autoconf, Automake,
libtool).

Bugs, feature requests and to-do list
=====================================

Report all bugs, feature requests and "to-do" items here:
  <https://bugs.freedesktop.org/enter_bug.cgi?product=Telepathy&component=tp-farstream>

Versioning policy
=================

We use an "odd/even" versioning scheme where the minor version (the y in
x.y.z) determines stability - stable branches have y even, development
branches have y odd.

Unreleased builds straight from Darcs identify themselves as version
"x.y.z.1". These are compiled with -Werror, so they might stop working
if your gcc version issues more warnings than ours. If this is a problem
for you, use a release tarball.

Contact info
============

This package is maintained by the Telepathy project:
  <http://telepathy.freedesktop.org/>
  <mailto:telepathy@lists.freedesktop.org>
  <irc://irc.freenode.net/telepathy>

Telepathy development is supported by Collabora Ltd.
  <http://www.collabora.co.uk/>.

Hacking
=======

The current version of telepathy-farstream is always available from:
  <http://git.collabora.co.uk/?p=telepathy-farstream.git;a=summary>

Please follow <http://telepathy.freedesktop.org/wiki/Style>.