Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Officially release 0.8.4

  • Loading branch information...
commit 02d6cfeb052f6508a3d696672e17edba965b12d1 1 parent bb896f1
@Havvy Havvy authored
View
1  doc/changelog.txt
@@ -180,7 +180,6 @@ Changelog
** Added localAddress (See irc-socket, net.Socket)
* Nick highlight command trigger case is now case-insensitive. (Thanks metalbot)
* Subscriber and Client gain .off() method which works as long as the event emitters has .removeListener or .off
- * Maybe .quit() will finally accept a reason properly.
0.9.0:
[Not yet done]
View
18 doc/dev/release-1_0_0-checklist.txt
@@ -5,15 +5,7 @@ Things not in this list are not considered critical for 1.0.0.
TODO
* Startup Object
-* Respond functionality
- * String (implemented)
- * Promise (implemented)
- * Object
- * query: boolean? (implemented)
- * intent: message | action (implemented)
- * target
- * message (implemented)
-* Default Modules
+* Default Plugins
* Help (implemented)
* Server
* Channel
@@ -22,14 +14,16 @@ TODO
* Promises for known commands.
* Plugin Reloading (if possible)
* Promise for .connect().
+* Rename modules to plugins.
FINISHED
-* MessageParser basic functionality
-* CommandParser
+* MessageHandler basic functionality
+* CommandHandler
* Plugin System
* On Method that delegates to CommandParser/MessageParser
* OutputSocket basic functionality
* Logging
* Command Line Tool
-* Nickname tracking object
+* Nickname tracking object
+* Respond Object (minus target property)
View
1  fez.js
@@ -9,5 +9,4 @@ exports.build = function(rule) {
};
exports.default = exports.build;
-
fez(module);
View
4 package.json
@@ -1,6 +1,6 @@
{
"name": "tennu",
- "version": "0.8.4pre4",
+ "version": "0.8.4",
"description": "Tennu - Modular IRC Bot Framework for Node.js",
"maintainers": [
{
@@ -39,7 +39,7 @@
"dependencies": {
"simplesets": "1.2.x",
"lodash": "2.4.x",
- "irc-socket": "~2.2.0pre2",
+ "irc-socket": "~2.2.0",
"irc-message": "1.0.x",
"tennu-modules": "2.1.x",
"commander": "~2.1.x",
Please sign in to comment.
Something went wrong with that request. Please try again.