Skip to content
Permalink
Browse files

discontinue support for Ruby versions below 2.0 (i.e., 1.9.3)

  • Loading branch information
kabaka committed Mar 18, 2016
1 parent 0ac7161 commit 41f68dbc62d6e02cd261ab3308feeed67f5c6ccb
Showing with 4 additions and 5 deletions.
  1. +1 −2 README.md
  2. +3 −3 terminus-bot
@@ -23,8 +23,7 @@ It is the first and primary project of the
# Requirements

* Linux
* Ruby 1.9.3 or 2.0 (**NOTICE: RUBY 1.9.3 IS NOT MAINTAINED; TERMINUS-BOT WILL
DISCONTINUE SUPPORT WITHIN DAYS**)
* Ruby 2.0 or above
* gems (mandatory)
* eventmachine (*should be built with SSL support*)
* psych (included psych has UTF-8 bugs)
@@ -26,11 +26,11 @@
#

# Don't comment this out. No, really.
unless RUBY_VERSION.start_with? '1.9' or RUBY_VERSION.start_with? '2'
abort 'Ruby version 1.9 or better is required.'
unless RUBY_VERSION.start_with? '2'
abort 'Ruby version 2.0 or better is required.'
end

VERSION = 'Terminus-Bot v0.8'
VERSION = 'Terminus-Bot v0.9'
PID_FILE = 'var/terminus-bot.pid'
LICENSE = 'MIT'

0 comments on commit 41f68db

Please sign in to comment.
You can’t perform that action at this time.