Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Moose::Autobox failure with Test-Builder2 #270

Closed
apeiron opened this Issue · 1 comment

2 participants

@apeiron
/Users/apeiron/perl5/perlbrew/perls/testbuilder2/bin/perl "-Iinc" "-MModule::Install::ExtraTests" "-e" "Module::Install::ExtraTests::__harness('Test::Harness', 0, '', 'xt/release', '', 0, 'blib/lib', 'blib/arch')" t/*.t
t/000_load.t ............... ok    
t/001_basic.t .............. ok    
t/002_role_hierarchy.t ..... ok    
t/003_p6_example.t ......... 1/? 
#   Failed test '... cannot do the autoboxing lexically'
#   at t/003_p6_example.t line 43.

#   Failed test '... no longer got 5 bytes'
#   at t/003_p6_example.t line 57.
# 2 tests of 8 failed.
t/003_p6_example.t ......... Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/8 subtests 
t/004_list_compressions.t .. ok   
t/005_string.t ............. ok    
t/006_y_combinator.t ....... ok   
t/007_base.t ............... ok   
t/008_flatten.t ............ ok   
t/009_number.t ............. ok   
t/010_each.t ............... ok    
t/011_each_n_values.t ...... ok    
t/012_first_last.t ......... ok   

Test Summary Report
-------------------
t/003_p6_example.t       (Wstat: 512 Tests: 8 Failed: 2)
  Failed tests:  7-8
  Non-zero exit status: 2
Files=13, Tests=213,  4 wallclock secs ( 0.10 usr  0.03 sys +  3.73 cusr  0.20 csys =  4.06 CPU)
Result: FAIL
Failed 1/13 test programs. 2/213 subtests failed.
make: *** [test_dynamic] Error 255
Testing Moose-Autobox-0.12 failed.
@schwern
Owner

Thanks. Repeat of #269. I'm going to close this up.

@schwern schwern closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.