Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Eliminate 5.4 and 5.5'isms from the documentation. #33

Closed
schwern opened this Issue May 27, 2010 · 1 comment

Comments

Projects
None yet
1 participant
Owner

schwern commented May 27, 2010

  • GC-ID: 19
  • GC-Labels: Type-Gardening, Priority-Low, Component-Docs
  • GC-Status: Accepted
  • GC-Attachments: No

Test::More now requires a minimum of 5.6 but it used to go back to 5.004.
There's a lot of code in the docs which is written with this in mind.
Replace it with good 5.6 practice.

What comes to mind...

  • like($have, "/regex/") instead of using qr//
  • open FH, $file instead of open my $fh, $file

Do a sweep of each bit of documentation.


Owner

schwern commented Nov 11, 2011

@jkeenan did a sweep of the docs and didn't find anything.

74a305c eliminated the last non-justified use of open BAREWORD in the code.

@schwern schwern closed this Nov 11, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment