New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Tracker for mods using Dependency Downloader. #12

Closed
covers1624 opened this Issue Oct 14, 2016 · 20 comments

Comments

Projects
None yet
8 participants
@covers1624
Member

covers1624 commented Oct 14, 2016

This issue is linked in the new version of the dependency downloader. Please comment a screenshot of the dependency downloader window that has linked you here. I will place the info in a table of mine and notify authors.

Back Story:
CodeChickenCore is going to be phased out entirely by my update to 1.11 (When it comes out). So in prep for that the DependencyDownloader needs to go away. This is the start of it, I need to have a list of mods still using the dependency downloader and inform the authors that they need to stop using it for what ever reason they are.
In addition to this CodeChickenLib will NOT be downloaded even if it is requested. Instead it will remove any CCL version from /mods/ and force people to have it in /mods and use a normal forge dpendency instead of the dependency downloader.
So. Tl;Dr CCC is going away, Deploader is cancer, CCL is not auto downloaded.

@Mrdlor

This comment has been minimized.

Show comment
Hide comment
@Mrdlor

Mrdlor Oct 16, 2016

As requested good sir :)

Brandon pushed a new build 2 hours ago with the changelog:
''Updates required for latest CCL changes''

So i'm not a 100% sure if his new build isn't fully working with the dependency check or if you got to change something. Hope this helps !

f

Mrdlor commented Oct 16, 2016

As requested good sir :)

Brandon pushed a new build 2 hours ago with the changelog:
''Updates required for latest CCL changes''

So i'm not a 100% sure if his new build isn't fully working with the dependency check or if you got to change something. Hope this helps !

f

@Zeevian

This comment has been minimized.

Show comment
Hide comment
@Zeevian

Zeevian Oct 16, 2016

The DepLoader un-installs the current version installed during loading and then doesn't download the new/correct version. Using Brandon's Core 1.10.2-2.1.0.51 as well Tried with CodeChickenLib 2.4.2.106 and 2.4.1.101

Zeevian commented Oct 16, 2016

The DepLoader un-installs the current version installed during loading and then doesn't download the new/correct version. Using Brandon's Core 1.10.2-2.1.0.51 as well Tried with CodeChickenLib 2.4.2.106 and 2.4.1.101

@Unrepentant-Atheist

This comment has been minimized.

Show comment
Hide comment
@covers1624

This comment has been minimized.

Show comment
Hide comment
@covers1624

covers1624 Oct 16, 2016

Member

@Zeevian The deploader will no longer auto install CCL you need to put it in your mods folder from curse, any CCL version inside mods/mcver will be auto removed.

Member

covers1624 commented Oct 16, 2016

@Zeevian The deploader will no longer auto install CCL you need to put it in your mods folder from curse, any CCL version inside mods/mcver will be auto removed.

@darkphan

This comment has been minimized.

Show comment
Hide comment
@darkphan

darkphan Oct 16, 2016

Would have been nice if there was some sort of config or what not that the CodeChickenLib kept track of locally so it would not have to pop up the window every single time a modpack was loaded with this in it...

darkphan commented Oct 16, 2016

Would have been nice if there was some sort of config or what not that the CodeChickenLib kept track of locally so it would not have to pop up the window every single time a modpack was loaded with this in it...

@covers1624

This comment has been minimized.

Show comment
Hide comment
@covers1624

covers1624 Oct 16, 2016

Member

you can add -Ddeploader.dontYellAtPeople=true to your java launch arguments to dissable it

Member

covers1624 commented Oct 16, 2016

you can add -Ddeploader.dontYellAtPeople=true to your java launch arguments to dissable it

@darkphan

This comment has been minimized.

Show comment
Hide comment
@darkphan

darkphan Oct 16, 2016

Ah, thanks!

darkphan commented Oct 16, 2016

Ah, thanks!

@archmage94

This comment has been minimized.

Show comment
Hide comment
@archmage94

archmage94 Oct 17, 2016

Tried that, the warning didn't show up but it still deleted the file

archmage94 commented Oct 17, 2016

Tried that, the warning didn't show up but it still deleted the file

@covers1624

This comment has been minimized.

Show comment
Hide comment
@covers1624

covers1624 Oct 17, 2016

Member

Yes, it stops the dialog but it will delete ANY file that contains "CodeChickenLib" in its name from /mods/mcver. Place CCL in your mods folder not /mods/mcver

Member

covers1624 commented Oct 17, 2016

Yes, it stops the dialog but it will delete ANY file that contains "CodeChickenLib" in its name from /mods/mcver. Place CCL in your mods folder not /mods/mcver

@archmage94

This comment has been minimized.

Show comment
Hide comment
@archmage94

archmage94 Oct 17, 2016

Well I downloaded CodeChickenCore and made sure CodeChickenLib was in my /mods folder and I still get the error

archmage94 commented Oct 17, 2016

Well I downloaded CodeChickenCore and made sure CodeChickenLib was in my /mods folder and I still get the error

@archmage94

This comment has been minimized.

Show comment
Hide comment
@archmage94

archmage94 Oct 17, 2016

http://hastebin.com/upolamohak.sql

But in all seriousness Brandon really needs to get rid of the dependency, I love Draconic Evolution too much

archmage94 commented Oct 17, 2016

http://hastebin.com/upolamohak.sql

But in all seriousness Brandon really needs to get rid of the dependency, I love Draconic Evolution too much

@tenten8401

This comment has been minimized.

Show comment
Hide comment
@tenten8401

tenten8401 Oct 17, 2016

I have CodeChickenCore 1.10.2-2.3.4.89 and CodeChickenLib 1.10.2-2.4.2.106 alongside Brandon's Core inside the /mods folder and it works great. If you need proof or just want a pack with draconic in it, download "IndustrialBox" on ATLauncher and copy the mods out from there.

Shameless self-promotion...

tenten8401 commented Oct 17, 2016

I have CodeChickenCore 1.10.2-2.3.4.89 and CodeChickenLib 1.10.2-2.4.2.106 alongside Brandon's Core inside the /mods folder and it works great. If you need proof or just want a pack with draconic in it, download "IndustrialBox" on ATLauncher and copy the mods out from there.

Shameless self-promotion...

@archmage94

This comment has been minimized.

Show comment
Hide comment
@archmage94

archmage94 Oct 17, 2016

I was trying to run CodeChickenLib 1.10.2-2.4.2.107. Could that have to do with it. Or perhaps it's one of my other mods?

archmage94 commented Oct 17, 2016

I was trying to run CodeChickenLib 1.10.2-2.4.2.107. Could that have to do with it. Or perhaps it's one of my other mods?

@tenten8401

This comment has been minimized.

Show comment
Hide comment
@tenten8401

tenten8401 Oct 17, 2016

Try it, I'm honestly not sure.

tenten8401 commented Oct 17, 2016

Try it, I'm honestly not sure.

@archmage94

This comment has been minimized.

Show comment
Hide comment
@archmage94

archmage94 Oct 17, 2016

And with a quick test, it has nothing to do with this issue at all, it's one of my other mods

archmage94 commented Oct 17, 2016

And with a quick test, it has nothing to do with this issue at all, it's one of my other mods

@archmage94

This comment has been minimized.

Show comment
Hide comment
@archmage94

archmage94 Oct 17, 2016

Yeah, it was Not Enough Items causing the problem (Obsolete mod I know with Just Enough Items) but I miss NEI cause it has more useful features

archmage94 commented Oct 17, 2016

Yeah, it was Not Enough Items causing the problem (Obsolete mod I know with Just Enough Items) but I miss NEI cause it has more useful features

@covers1624

This comment has been minimized.

Show comment
Hide comment
@covers1624

covers1624 Oct 18, 2016

Member

Brandon is not going to get rid of the CCL dependency as it has lots of key features he is using behind the scenes. Like @tenten8401 is saying, it just works. Always make sure you have the latest mods before submitting any crash reports. ima remove most of the comments before this one.

Member

covers1624 commented Oct 18, 2016

Brandon is not going to get rid of the CCL dependency as it has lots of key features he is using behind the scenes. Like @tenten8401 is saying, it just works. Always make sure you have the latest mods before submitting any crash reports. ima remove most of the comments before this one.

@archmage94

This comment has been minimized.

Show comment
Hide comment
@archmage94

archmage94 commented Oct 18, 2016

K

@Notawallplan

This comment has been minimized.

Show comment
Hide comment
@Notawallplan

Notawallplan Nov 12, 2016

"Modularity-[1.10.2]-0.1.0.jar" Wants: CodeChickenLib-2.2.3.57

Due to Curse, this is the latest version of this mod.

Edit: Please turn the popup box into an actual window.

Notawallplan commented Nov 12, 2016

"Modularity-[1.10.2]-0.1.0.jar" Wants: CodeChickenLib-2.2.3.57

Due to Curse, this is the latest version of this mod.

Edit: Please turn the popup box into an actual window.

@covers1624

This comment has been minimized.

Show comment
Hide comment
@covers1624

covers1624 Jan 8, 2017

Member

Closing this due to no mods are using the dep loader.

Member

covers1624 commented Jan 8, 2017

Closing this due to no mods are using the dep loader.

@covers1624 covers1624 closed this Jan 8, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment