Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Bug] abuselpdb stop stupport APIv1 #618

Closed
KRUXLEX opened this issue Feb 11, 2020 · 1 comment
Closed

[Bug] abuselpdb stop stupport APIv1 #618

KRUXLEX opened this issue Feb 11, 2020 · 1 comment
Assignees
Labels
bug
Milestone

Comments

@KRUXLEX
Copy link

@KRUXLEX KRUXLEX commented Feb 11, 2020

Describe the bug
Officially AbuselPDB stop support his own APIv1. They start working on APIv2.

To Reproduce
Run Analyzer normlany

Expected behavior
Working

Complementary information

{
  "values": [
    {
      "detail": "The APIv1 check endpoint has sunset. Please migrate to the APIv2 version of this endpoint. You will need a new API key.",
      "links": {
        "related": "https://docs.abuseipdb.com/#check-endpoint"
      },
      "status": 404
    }
  ]
}

Work environment

  • Client OS: Debian9
  • Server OS: Centos8
  • Browse type and version: Mozzilla
  • Cortex version: 3.4.0-1
  • Cortex Analyzer/Responder name: AbuseIPDB_1_0
  • Cortex Analyzer/Responder version:AbuseIPDB

Possible solutions
Convert script to new varsion of API. Using a GET metod:

import requests
import json

# Defining the api-endpoint
url = 'https://api.abuseipdb.com/api/v2/check'

querystring = {
    'ipAddress': '118.25.6.39',
    'maxAgeInDays': '90'
}

headers = {
    'Accept': 'application/json',
    'Key': '$YOUR_API_KEY'
}

response = requests.request(method='GET', url=url, headers=headers, params=querystring)

# Formatted output
decodedResponse = json.loads(response.text)
print(json.dumps(decodedResponse, sort_keys=True, indent=4))
 

Additional context
nOpe

@KRUXLEX KRUXLEX added the bug label Feb 11, 2020
@KRUXLEX KRUXLEX changed the title [Bug] abuseipdb stop stupport APIv1 [Bug] abuselpdb stop stupport APIv1 Feb 14, 2020
@jeromeleonard jeromeleonard added this to the 2.6.0 milestone Feb 24, 2020
@jeromeleonard jeromeleonard self-assigned this Feb 28, 2020
@dadokkio dadokkio self-assigned this Mar 14, 2020
@dadokkio

This comment has been minimized.

Copy link
Contributor

@dadokkio dadokkio commented Mar 18, 2020

closed in 2.6.0

@dadokkio dadokkio closed this Mar 18, 2020
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
3 participants
You can’t perform that action at this time.