New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wrong error message when creating a observable with invalid data #592

Closed
To-om opened this Issue May 24, 2018 · 0 comments

Comments

Projects
None yet
1 participant
@To-om
Contributor

To-om commented May 24, 2018

Request Type

Bug

Work Environment

Question Answer
OS version (server) Ubuntu
OS version (client) Ubuntu, ...
TheHive version / git hash <= 3.0.9
Package Type DEB
Browser type & version If applicable

Problem Description

When one tries to create an observable with invalid data (TLP=4 for example), TheHive says that the observable already exists (even if it doesn't exist).

Steps to Reproduce

$ curl -s \
  -H 'Authorization: bearer ** API KEY **' \
  -H 'Content-type: application/json' \
  http://127.0.0.1:9000/api/case/AWMlW5wS695cfl3hKzHL/artifact \
  -d '{"data":"127.0.0.1","dataType":"ip","tlp":4,"message":"localhost"}'

returns

{
  "type": "ConflictError",
  "message": "Artifact already exists",
  "object": {
    "data": "127.0.0.1",
    "dataType": "ip",
    "tlp": 10,
    "message": "localhost"
  }
}

@To-om To-om added the bug label May 24, 2018

@To-om To-om added this to the 3.0.10 milestone May 24, 2018

@To-om To-om self-assigned this May 24, 2018

@To-om To-om closed this May 24, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment