New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

event-table-edit is not compatible with PHP-Version 7.0 and 7.1 ? #65

Closed
MalikMoses opened this Issue May 27, 2017 · 5 comments

Comments

Projects
None yet
2 participants
@MalikMoses

MalikMoses commented May 27, 2017

Warning:
After updating der PHP-Version on the server from version 5.6 to 7.0 using Joomla 3.6.5
Event-Table-Edit was not working any more.

Trying to fill a field in the table (Frontend) results in PHP-Error-Messages written into the Table

@Theophilix

This comment has been minimized.

Owner

Theophilix commented May 28, 2017

Please post the error messages.
You could try to uninstall ETE and delete all MYSQL entries and make a clean install.
And yes, there are problems with Joomla 3.7x, but there shouldn't be with 3.6.5 and PHP 7.0 or 7.1 (see demo.eventtableedit.com, it works well with Joomla 3.6.5 and PHP 7.1)
Maybe your error reports are on the highest level.

@MalikMoses

This comment has been minimized.

MalikMoses commented May 28, 2017


Here are the Error messages, in fact only one Warning message several times, but very nasty.

At the top of the page shown I get:

Warning: Declaration of EventtableeditModelEtetable::populateState() should be compatible with JModelList::populateState($ordering = NULL, $direction = NULL) in /www/htdocs/homepage/components/com_eventtableedit/models/etetable.php on line 15

Filling in a cell of the table I get the same massage either in the Popup-Menue where I should type the text or the date, or in formated manner written in the Cell in case of list of choices:


Warning: Declaration of EventtableeditModelEtetable::populateState() should be compatible with JModelList::populateState($ordering = NULL, $direction = NULL) in /www/htdocs/homepage/components/com_eventtableedit/models/etetable.php on line 15
------------------------------

Both debugging options in Joomla are switched off, and I could not find any choice in the admin-menues to reduce the error-level not to show this warning.

I don't like to unistall ETE compltetly and delete all entries in the database as suggested,, because it will cost me many hours of work to fill in again all data manually in lhe tables created so far.

any Ideas for a work-around?

@MalikMoses MalikMoses closed this May 28, 2017

@Theophilix

This comment has been minimized.

Owner

Theophilix commented May 28, 2017

try this: in file site/models/etetable.php: delete the values in the parentheses at : "protected function populateState($ordering = NULL, $direction = NULL)", so you get: "protected function populateState()" Please reply if this does not work.

@Theophilix Theophilix reopened this May 28, 2017

@MalikMoses

This comment has been minimized.

MalikMoses commented May 29, 2017

Doing the exact opposite of your suggestion was successful :-))
I changed: protected function populateState()
to: protected function populateState($ordering = NULL, $direction = NULL)

Thank you for your support and for keeping Evet Table Edit alive !

@MalikMoses MalikMoses closed this May 29, 2017

@Theophilix

This comment has been minimized.

Owner

Theophilix commented May 29, 2017

Happy I could help you!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment