Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Does not support RPi 3? #3

Open
adazoom opened this issue Apr 3, 2016 · 5 comments

Comments

Projects
None yet
4 participants
@adazoom
Copy link

commented Apr 3, 2016

Downloaded all of the required programs via luarocks as described in readme. When I run test_leds.lua on my RPi 3 it prints "This module can only be run on a Raspberry Pi!" for the line local GPIO=require "GPIO". Is there any way to fix that?

@Tieske

This comment has been minimized.

Copy link
Owner

commented Apr 4, 2016

Some major updates are required to the package, unfortunately its been sitting on my todo list for quite a while now, waiting for me to get some time to fix it.

So for now, it does not support version 3...

@fuzzy

This comment has been minimized.

Copy link

commented Aug 12, 2017

It doesn't support the Pi2B either. Same issue.

@Tieske

This comment has been minimized.

Copy link
Owner

commented Sep 5, 2017

@wangqiang1588

This comment has been minimized.

Copy link

commented Oct 8, 2018

please merge the pull request ,the crash bug is cpu type check incorrect cause "pin_to_gpio" on RPi_GPIO_Lua_module.c undefined value, raspberry pi zero w and raspberry 3b

@Tieske

This comment has been minimized.

Copy link
Owner

commented Oct 8, 2018

done

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.