Permalink
Browse files

Fixing dependencies

  • Loading branch information...
lucasefe committed Nov 16, 2011
1 parent 7271a26 commit a0d3a0e6142f997d8637f4dc5166fe43be42043a
Showing with 26 additions and 192 deletions.
  1. +1 −0 Gemfile.lock
  2. +0 −173 Gemfile.lock.old
  3. +9 −11 Rakefile
  4. +9 −3 spec/lib/view_helpers_spec.rb
  5. +7 −5 themes_for_rails.gemspec
View
@@ -2,6 +2,7 @@ PATH
remote: .
specs:
themes_for_rails (1.0.0rc1)
+ rails (~> 3.1.0)
themes_for_rails
GEM
View
@@ -1,173 +0,0 @@
-PATH
- remote: .
- specs:
-<<<<<<< HEAD
- themes_for_rails (0.4.2)
- rails (~> 3.0.0)
- themes_for_rails
-=======
- themes_for_rails (1.0.0)
- rails (~> 3.1)
- themes_for_rails (>= 1.0)
->>>>>>> rails3.1
-
-GEM
- remote: http://rubygems.org/
- specs:
-<<<<<<< HEAD
- abstract (1.0.0)
- actionmailer (3.0.5)
- actionpack (= 3.0.5)
- mail (~> 2.2.15)
- actionpack (3.0.5)
- activemodel (= 3.0.5)
- activesupport (= 3.0.5)
- builder (~> 2.1.2)
- erubis (~> 2.6.6)
- i18n (~> 0.4)
- rack (~> 1.2.1)
- rack-mount (~> 0.6.13)
- rack-test (~> 0.5.7)
- tzinfo (~> 0.3.23)
- activemodel (3.0.5)
- activesupport (= 3.0.5)
- builder (~> 2.1.2)
- i18n (~> 0.4)
- activerecord (3.0.5)
- activemodel (= 3.0.5)
- activesupport (= 3.0.5)
- arel (~> 2.0.2)
- tzinfo (~> 0.3.23)
- activeresource (3.0.5)
- activemodel (= 3.0.5)
- activesupport (= 3.0.5)
- activesupport (3.0.5)
- arel (2.0.10)
- builder (2.1.2)
- contest (0.1.2)
- diff-lcs (1.1.2)
- erubis (2.6.6)
- abstract (>= 1.0.0)
- git (1.2.5)
- i18n (0.5.0)
- jeweler (1.5.2)
- bundler (~> 1.0.0)
- git (>= 1.2.5)
- rake
- mail (2.2.19)
- activesupport (>= 2.3.6)
-=======
- actionmailer (3.1.0)
- actionpack (= 3.1.0)
- mail (~> 2.3.0)
- actionpack (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
- builder (~> 3.0.0)
- erubis (~> 2.7.0)
- i18n (~> 0.6)
- rack (~> 1.3.2)
- rack-cache (~> 1.0.3)
- rack-mount (~> 0.8.2)
- rack-test (~> 0.6.1)
- sprockets (~> 2.0.0)
- activemodel (3.1.0)
- activesupport (= 3.1.0)
- bcrypt-ruby (~> 3.0.0)
- builder (~> 3.0.0)
- i18n (~> 0.6)
- activerecord (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
- arel (~> 2.2.1)
- tzinfo (~> 0.3.29)
- activeresource (3.1.0)
- activemodel (= 3.1.0)
- activesupport (= 3.1.0)
- activesupport (3.1.0)
- multi_json (~> 1.0)
- arel (2.2.1)
- bcrypt-ruby (3.0.1)
- builder (3.0.0)
- diff-lcs (1.1.3)
- erubis (2.7.0)
- hike (1.2.1)
- i18n (0.6.0)
- mail (2.3.0)
->>>>>>> rails3.1
- i18n (>= 0.4.0)
- mime-types (~> 1.16)
- treetop (~> 1.4.8)
- mime-types (1.16)
-<<<<<<< HEAD
- mocha (0.9.12)
- polyglot (0.3.2)
- rack (1.2.1)
- rack-mount (0.6.13)
-=======
- multi_json (1.0.3)
- polyglot (0.3.2)
- rack (1.3.4)
- rack-cache (1.0.3)
- rack (>= 0.4)
- rack-mount (0.8.3)
->>>>>>> rails3.1
- rack (>= 1.0.0)
- rack-ssl (1.3.2)
- rack
- rack-test (0.6.1)
- rack (>= 1.0)
- rails (3.1.0)
- actionmailer (= 3.1.0)
- actionpack (= 3.1.0)
- activerecord (= 3.1.0)
- activeresource (= 3.1.0)
- activesupport (= 3.1.0)
- bundler (~> 1.0)
- railties (= 3.1.0)
- railties (3.1.0)
- actionpack (= 3.1.0)
- activesupport (= 3.1.0)
- rack-ssl (~> 1.3.2)
- rake (>= 0.8.7)
- rdoc (~> 3.4)
- thor (~> 0.14.6)
- rake (0.9.2)
- rdoc (3.9.4)
- rspec (2.6.0)
- rspec-core (~> 2.6.0)
- rspec-expectations (~> 2.6.0)
- rspec-mocks (~> 2.6.0)
- rspec-core (2.6.4)
- rspec-expectations (2.6.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.6.0)
- rspec-rails (2.6.1)
- actionpack (~> 3.0)
- activesupport (~> 3.0)
- railties (~> 3.0)
- rspec (~> 2.6.0)
- sprockets (2.0.2)
- hike (~> 1.2)
- rack (~> 1.0)
- tilt (~> 1.1, != 1.3.0)
- sqlite3 (1.3.4)
- thor (0.14.6)
-<<<<<<< HEAD
-=======
- tilt (1.3.3)
->>>>>>> rails3.1
- treetop (1.4.10)
- polyglot
- polyglot (>= 0.3.1)
- tzinfo (0.3.30)
-
-PLATFORMS
- ruby
-
-DEPENDENCIES
- rails (~> 3.1)
- rspec
- rspec-rails
- sqlite3
- themes_for_rails!
View
@@ -2,20 +2,18 @@
require File.dirname(__FILE__) + "/lib/themes_for_rails/version.rb"
require 'rake'
-require 'rake/testtask'
-require 'rake/rdoctask'
+require 'rspec/core'
+require 'rspec/core/rake_task'
-desc 'Default: run tests for all ORMs.'
-task :default => :test
+desc 'Default: run rspec for all'
+task :default => :spec
-desc 'Run unit tests.'
-Rake::TestTask.new(:test) do |t|
- t.libs << 'lib'
- t.libs << 'test'
- t.pattern = 'test/**/*_test.rb'
- t.verbose = true
+desc "Run the code examples"
+RSpec::Core::RakeTask.new(:spec ) do |t|
+ t.pattern = "./spec/**/*_spec.rb"
end
+
begin
require 'jeweler'
Jeweler::Tasks.new do |gemspec|
@@ -26,7 +24,7 @@ begin
gemspec.homepage = "http://github.com/lucasefe/themes_for_rails"
gemspec.authors = ["Lucas Florio"]
gemspec.version = ThemesForRails::VERSION
- gemspec.add_dependency "rails", "> 3.0.0"
+ gemspec.add_dependency "rails", "~> 3.1.0"
end
rescue LoadError
puts "Jeweler not available. Install it with: gem install jeweler"
@@ -3,11 +3,17 @@
describe ThemesForRails::ViewHelpers do
let(:helper) do
- Class.new do
+ config = stub({:perform_caching => false,
+ :asset_path => "/assets",
+ :relative_url_root => nil,
+ :default_asset_host_protocol => nil,
+ :asset_host => ''})
+
+ Class.new(ActionView::AssetPaths) do
attr_accessor :theme_name
include ThemesForRails::ViewHelpers
- include Sprockets::Helpers::RailsHelper
- end.new
+ include Sprockets::Helpers::RailsHelper
+ end.new(config)
end
it "should provide path helpers for common asset formats" do
View
@@ -105,6 +105,7 @@ Gem::Specification.new do |s|
"spec/lib/view_helpers_spec.rb",
"spec/mailers/mailer_methods_spec.rb",
"spec/spec_helper.rb",
+ "test/dummy_app/Gemfile.lock",
"test/dummy_app/log/development.log",
"test/dummy_app/log/test.log",
"themes_for_rails.gemspec"
@@ -123,21 +124,22 @@ Gem::Specification.new do |s|
s.add_development_dependency(%q<sqlite3>, [">= 0"])
s.add_development_dependency(%q<rspec>, [">= 0"])
s.add_development_dependency(%q<rspec-rails>, [">= 0"])
+ s.add_runtime_dependency(%q<rails>, ["~> 3.1.0"])
else
s.add_dependency(%q<themes_for_rails>, [">= 0"])
s.add_dependency(%q<rails>, ["~> 3.1"])
s.add_dependency(%q<sqlite3>, [">= 0"])
s.add_dependency(%q<rspec>, [">= 0"])
- s.add_dependency(%q<rspec-rails>, [">= 2.0.0.beta.20"])
+ s.add_dependency(%q<rspec-rails>, [">= 0"])
+ s.add_dependency(%q<rails>, ["~> 3.1.0"])
end
else
s.add_dependency(%q<themes_for_rails>, [">= 0"])
s.add_dependency(%q<rails>, ["~> 3.1"])
s.add_dependency(%q<sqlite3>, [">= 0"])
- s.add_dependency(%q<rspec-rails>, [">= 2.0.0.beta.20"])
- s.add_dependency(%q<jeweler>, [">= 0"])
- s.add_dependency(%q<contest>, [">= 0"])
- s.add_dependency(%q<mocha>, [">= 0"])
+ s.add_dependency(%q<rspec>, [">= 0"])
+ s.add_dependency(%q<rspec-rails>, [">= 0"])
+ s.add_dependency(%q<rails>, ["~> 3.1.0"])
end
end

0 comments on commit a0d3a0e

Please sign in to comment.