Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Incorrect integer value: 'NULL' #304

Closed
Moowalker opened this issue Feb 12, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@Moowalker
Copy link

commented Feb 12, 2019

After upgrading my forum from 2.0.15 for 2.1RC1 and installing Tinyportal 1.6.2 I get the following error during TP installation

Incorrect integer value: 'NULL' for column ..eventid at row 1
File: /home/infinite/public_html/Packages/temp/install.php
Line: 379

I did uninstall TP 1.6.1 before doing the installation of TP 1.6.2

@tinoest

This comment has been minimized.

Copy link
Contributor

commented Feb 13, 2019

Try changing https://github.com/Tinyportal/TinyPortal/blob/master/install.php#L314 to default => 0

What version of MySQL are you using as this doesn't break for me.

@tinoest tinoest added this to the 1.6.3 milestone Feb 24, 2019

@tinoest tinoest closed this in 8c16b63 Feb 24, 2019

tinoest added a commit that referenced this issue Feb 24, 2019

Merge pull request #308 from tinoest/master
Changed null to 0 for default values fixes #304
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.