Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Not sure what... (installing crypto-api fails, maybe just me) #2

Closed
gnimmelf opened this Issue · 4 comments

2 participants

@gnimmelf

hi, sorry to bother, but I'm not sure where to ask this, or how to; I'm very new to haskell...

Tried installing yesod, and it sort of failed; I killed it after 5 minutes of waiting for this
[2 of 9] Compiling Crypto.CPoly ( Crypto/CPoly.hs, dist/build/Crypto/CPoly.o )

The version is 0.7 from hackage. I got the latest version from your repo here, but I'm not well versed enough to 'install' the git clone manually.

I read now that the CPoly class is/was pretty big, so maybe I'm just too impatient?

Anyhow, hope you have time to reply on this, any pointers appreciated =)

Cheers,
FlemmingH

@TomMD
Owner
@TomMD
Owner
@gnimmelf

Hi,

I left cabal running in a screen overnight now, and indeed it did finnsih, albeit with a lot of
Crypto/Modes.hs:582:0: Unrecognised pragma
-lines.

I will try 0.8, and also the optimization switch, this evening.

Thank you a lot for the swift replies and fix. =)

//FlemmingH

@gnimmelf gnimmelf closed this
@gnimmelf gnimmelf reopened this
@gnimmelf gnimmelf closed this
@gnimmelf

Disregard the reopening & closing of this issue, didn't see right away that it was you who answered the stackoverflow question linked to below.


Hi again,

installed 0.8, and it was a lot faster. Then I went on to yesod (0.9.3):

~$ cabal install yesod
Resolving dependencies...
cabal: cannot configure cprng-aes-0.2.2. It requires crypto-api >=0.8
For the dependency on crypto-api >=0.8 there are these packages:
crypto-api-0.8. However none of them are available.
crypto-api-0.8 was excluded because skein-0.1.0.1 requires crypto-api ==0.6.*
crypto-api-0.8 was excluded because crypto-api-0.6.4 was selected instead
crypto-api-0.8 was excluded because clientsession-0.7.3.1 requires crypto-api

=0.6.4 && <0.7

...this seems a rather odd dependency list?

Just saw this now, posted 5 hrs ago, so prob related to this ticket,
http://stackoverflow.com/questions/7860155/issues-installing-yesod

Not sure if this is yours to fix, but I reopened this issue.

Cheers & thanks again,
//FlemmingH

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.