Permalink
Switch branches/tags
Nothing to show
Find file Copy path
Fetching contributors…
Cannot retrieve contributors at this time
executable file 39 lines (26 sloc) 1.03 KB
title template chapter
Get Started
documentation.twig::content_inner
1

Installation

Server Requirements

Skosh has a few system requirements:

  • PHP >= 5.4.0
  • Node

Installing Skosh

Skosh utilizes Composer to manage its dependencies. So, before using Skosh, make sure you have Composer installed on your machine.

You may also install Laravel by issuing the Composer create-project command in your terminal:

composer create-project torann/skosh --prefer-dist

Gulp

Next, you'll want to pull in Gulp as a global NPM package

npm install --global gulp-cli

This will put the Gulp command in your system path, allowing it to be run from any directory.

The only remaining step is to install the Node dependencies. Within a fresh installation of Skosh, you'll find a package.json file in the root. Think of this like your composer.json file, except it defines Node dependencies instead of PHP. You may install the dependencies it references by running:

npm install