Join GitHub today
GitHub is home to over 31 million developers working together to host and review code, manage projects, and build software together.Sign up
Consider yarn network timeouts #641
Original slack thread: https://ghost.slack.com/archives/C04CUS2R3/p1518440412000159
A user on slack tried to install Ghost 1.0 but ran into network timeout errors from yarn. This happened on a raspberry pi, so counts as "other stack" but there are a few interesting things:
This could happen on a very slow ubuntu machine, and although there is a workaround for now, we should IMO consider improving error handling and also either extending or exposing the yarn config.
The user managed to solve the problem themselves:
referenced this issue
Apr 6, 2018
Any ideas of what else I could try would be much appreciated!
I'm running into a related issue trying to update from 2.6.0 to 2.8.0.
First i tried
Then i visited your ghost releases github page and tried to install all the latest versions, one by one to check which latest version i could install:
All these versions got me the same error described above:
And finally i could make a fresh ghost install with this version:
ghost install 2.11.1
My Ubuntu 16.04 was using less than 59% of RAM memory and the disk usage was around 65% at the time of getting these errors, and a the time of finally installing ghost 2.11.1
But i must say that Before i got these errors my Ubuntu 16.04 server had close to 80% RAM used, So i freed a lot of memory by running ghost uninstall to a lot of blogs i was not using. (around 6 blogs) When i had my ram at 58-59% that when i tried to run ghost install, getting the error described above.
I am thinking, maybe all those newest versions of ghost needed node 8 to get installed? But then why @lizrodriguez got the exact same error. She was using node 8.
@lmuzquiz The errors are different - the error Liz got related to one of Ghost's dependencies being hosted on github, but the system not having a suitable git client installed to download. Your error relates to your node version -
What this means is you need to update your node version to the latest 6.x release. If you followed the installation guide, the should be as simple as running