Skip to content

MineCraft 1.13

pop4959 edited this page Sep 4, 2018 · 1 revision

Important information for upgrading

Due to the significant changes in 1.13, older versions of Modern LWC are no longer supported. However, they can be downloaded from the Modern LWC Spigot Resource Page.

We currently support the following

Modern LWC 1.9.4 (and above) for MineCraft 1.12 and prior.

Modern LWC 2.1.x (and above) for MineCraft 1.13.

Database upgrade from 1.12 -> 1.13

To upgrade your database from Modern LWC 1.9.4, simply download the latest version of Modern LWC (2.1.0 or higher) and place it in your plugins folder. Make sure that no other version of LWC is installed. Then, simply start the server, and your database should automatically be upgraded. Warning: It is highly recommended to make a backup of your database before performing the upgrade (ie. find "lwc.db" in plugins/LWC and copy it somewhere). Once the database is upgraded, it should fully support 1.13. However, please keep in mind that this is a permanent upgrade, and you cannot use the database on versions prior to 1.13 once you have upgraded it.

Configuration changes required for 1.13

The default configuration for Modern LWC 2.1.0 (or higher) has been updated to fully support 1.13. It includes many new blocks, as well as blocks that were renamed. On a fresh install of Modern LWC, these configuration files will be automatically created for you. If you are using an outdated version of Modern LWC (prior to 2.1.0), you will need to delete or move your core.yml and magnet.yml. Once you do so, the server will automatically create a new one for you when you start your server.

You can’t perform that action at this time.