Skip to content
Browse files

Make genshi always available to have a lingua franca for pluggable ap…

…ps and extensions
  • Loading branch information...
1 parent ccfd9fb commit 563e28d86890896aca37bbcadd22a6e7e6054cac @amol- amol- committed Apr 12, 2012
View
6 devtools/templates/turbogears/+package+/config/app_cfg.py_tmpl
@@ -30,6 +30,11 @@ base_config.package = {{package}}
#Enable json in expose
base_config.renderers.append('json')
+
+#Enable genshi in expose to have a lingua franca for extensions and pluggable apps
+#you can remove this if you don't plan to use it.
+base_config.renderers.append('genshi')
+
#Set the default renderer
{{if mako == 'True' or template_engine == 'mako'}}
base_config.default_renderer = 'mako'
@@ -40,7 +45,6 @@ base_config.renderers.append('jinja')
base_config.jinja_extensions = ['jinja2.ext.with_']
{{elif template_engine == 'genshi'}}
base_config.default_renderer = 'genshi'
-base_config.renderers.append('genshi')
# if you want raw speed and have installed chameleon.genshi
# you should try to use this renderer instead.
# warning: for the moment chameleon does not handle i18n translations
View
8 devtools/templates/turbogears/setup.py_tmpl
@@ -24,12 +24,11 @@ testpkgs=['WebTest >= 1.2.3',
]
install_requires=[
"TurboGears2 >= 2.2.0rc1",
+ "Genshi",
{{if mako == 'True'}}
"Mako",
{{elif jinja == 'True'}}
"Jinja2",
- {{else}}
- "Genshi",
{{endif}}
{{if sqlalchemy == 'True'}}
"zope.sqlalchemy >= 0.4",
@@ -46,7 +45,7 @@ install_requires=[
"repoze.what >= 1.0.8",
"repoze.who-friendlyform >= 1.0.4",
"repoze.who==1.0.19",
- "tgext.admin >= 0.3.11",
+ "tgext.admin >= 0.5",
{{endif}}
{{if auth == "sqlalchemy"}}
"repoze.who.plugins.sa",
@@ -57,9 +56,6 @@ install_requires=[
{{else}}
"tw2.forms",
{{endif}}
- {{if auth == "ming"}}
- "sprox >= 0.7dev",
- {{endif}}
]
setup(

0 comments on commit 563e28d

Please sign in to comment.
Something went wrong with that request. Please try again.