Skip to content
Browse files

updating to latest version of rspec

  • Loading branch information...
1 parent 46a1876 commit 0a9559442cfb5c047034840386f7b2a71798dadc @TwP committed Nov 17, 2011
Showing with 8 additions and 20 deletions.
  1. +8 −8 spec/little-plugger_spec.rb
  2. +0 −12 spec/spec_helper.rb
View
16 spec/little-plugger_spec.rb
@@ -4,22 +4,22 @@
describe LittlePlugger do
it "converts a string from camel-case to underscore" do
- LittlePlugger.underscore('FooBarBaz').should == 'foo_bar_baz'
- LittlePlugger.underscore('CouchDB').should == 'couch_db'
- LittlePlugger.underscore('FOOBar').should == 'foo_bar'
- LittlePlugger.underscore('Foo::Bar::BazBuz').should == 'foo/bar/baz_buz'
+ LittlePlugger.underscore('FooBarBaz').should be == 'foo_bar_baz'
+ LittlePlugger.underscore('CouchDB').should be == 'couch_db'
+ LittlePlugger.underscore('FOOBar').should be == 'foo_bar'
+ LittlePlugger.underscore('Foo::Bar::BazBuz').should be == 'foo/bar/baz_buz'
end
it "generates a default plugin path" do
- LittlePlugger.default_plugin_path(LittlePlugger).should == 'little_plugger/plugins'
- LittlePlugger.default_plugin_path(Spec::Runner).should == 'spec/runner/plugins'
+ LittlePlugger.default_plugin_path(LittlePlugger).should be == 'little_plugger/plugins'
+ LittlePlugger.default_plugin_path(Process::Status).should be == 'process/status/plugins'
end
it "generates a default plugin module" do
- LittlePlugger.default_plugin_module('little_plugger').should == LittlePlugger
+ LittlePlugger.default_plugin_module('little_plugger').should be == LittlePlugger
lambda {LittlePlugger.default_plugin_module('little_plugger/plugins')}.
should raise_error(NameError, 'uninitialized constant LittlePlugger::Plugins')
- LittlePlugger.default_plugin_module('spec/runner').should == Spec::Runner
+ LittlePlugger.default_plugin_module('process/status').should be == Process::Status
end
end
View
12 spec/spec_helper.rb
@@ -2,15 +2,3 @@
require File.expand_path(
File.join(File.dirname(__FILE__), %w[.. lib little-plugger]))
-Spec::Runner.configure do |config|
- # == Mock Framework
- #
- # RSpec uses it's own mocking framework by default. If you prefer to
- # use mocha, flexmock or RR, uncomment the appropriate line:
- #
- # config.mock_with :mocha
- # config.mock_with :flexmock
- # config.mock_with :rr
-end
-
-# EOF

0 comments on commit 0a95594

Please sign in to comment.
Something went wrong with that request. Please try again.