Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

failed to install uuagc-cabal on OSX 10.6.8 #4

Open
gzmask opened this Issue Jun 21, 2012 · 7 comments

Comments

Projects
None yet
4 participants

gzmask commented Jun 21, 2012

cabal install uuagc --reinstall
Resolving dependencies...
Configuring uuagc-bootstrap-0.9.40.2...
Building uuagc-bootstrap-0.9.40.2...
Preprocessing executable 'uuagc-bootstrap' for uuagc-bootstrap-0.9.40.2...
: cannot satisfy -package-id mtl-2.1.1-ae9b44386a2528180e60dcf2412689c0
(use -v for more information)
Configuring uuagc-cabal-1.0.2.0...
Building uuagc-cabal-1.0.2.0...
Preprocessing library uuagc-cabal-1.0.2.0...
: cannot satisfy -package-id mtl-2.1.1-ae9b44386a2528180e60dcf2412689c0
(use -v for more information)
cabal: Error: some packages failed to install:
uuagc-0.9.40.3 depends on uuagc-cabal-1.0.2.0 which failed to install.
uuagc-bootstrap-0.9.40.2 failed during the building phase. The exception was:
ExitFailure 1
uuagc-cabal-1.0.2.0 failed during the building phase. The exception was:
ExitFailure 1

@gzmask gzmask closed this Jun 21, 2012

@gzmask gzmask reopened this Jun 21, 2012

Member

jbransen commented Jun 22, 2012

Have you done "cabal update" before this? Mtl-2.1.1 is available from hackage (http://hackage.haskell.org/package/mtl-2.1.1) and is the latest version, so I am not sure why it would not be able to satisfy that dependency.

And what if you run "cabal install mtl-2.1.1" first?

gzmask commented Jun 22, 2012

yes, I did cabal update before. and mtl-2.1.1 is there:

cabal install mtl-2.1.1
Resolving dependencies...
All the requested packages are already installed:
mtl-2.1.1
Use --reinstall if you want to reinstall anyway.

Member

jbransen commented Jun 22, 2012

What is the output of running cabal install uuagc --reinstall -v ?

gzmask commented Jun 22, 2012

I successfully installed uuagc with cabal install uuagc --reinstall -v
however, ./configure still reports:

uuagc is available? : no
**** ERROR **** : uuagc must be installed, use (1) cabal+hackage, or (2) http://www.cs.uu.nl/wiki/HUT

I guess the configure script might be checking the wrong place for uuagc on OSX ?

Member

jbransen commented Jun 23, 2012

I think you must have changed something in your installation, as the "-v" option should not have changed the behaviour of the install, only printing more debug information.

When uuagc is installed, it should be a binary in "~/.cabal/bin" named "uuagc". Please check that it exists. I guess that the cabal in directory is not in your path and that is why configure cannot find uuagc. There are two ways to fix this problem:

  1. Add it to you path, so do something like export PATH="/Users//.cabal/bin:$PATH";
  2. Tell configure where to find uuagc, by using ./configure --with-uuagc=/Users//.cabal/bin/uuagc
Member

spockz commented Sep 11, 2012

@gzmask could you confirm whether you still have this issue?

tobi512 commented Nov 15, 2015

The solution of @jbransen fixes the problem. However, the installation directory has changes and is now in ~/Library/Haskell/bin (also pointed out in a text file named "where-is-my-stuff.txt" under ~/.cabal).
export PATH="$HOME/Library/Haskell/bin:$PATH" is the way to go, then ./configure works...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment