npm update jquery and now jsdom not working #17

Closed
cjroebuck opened this Issue Sep 13, 2011 · 4 comments

Comments

Projects
None yet
3 participants
@cjroebuck

I just ran npm update, and it complains:

TypeError: Object #<Object> has no method 'jsdom'
    at create (/Users/cjroebuck/Dev/Quillu/foto/node_modules/jquery/node-jquery.js:5:39)
    at /Users/cjroebuck/Dev/Quillu/foto/node_modules/jquery/node-jquery.js:9066:18
    at Object.<anonymous> (/Users/cjroebuck/Dev/Quillu/foto/node_modules/jquery/node-jquery.js:9068:1)

jquery is version 1.6.3

reverting to jquery@1.6.2 fixes this issue

@coolaj86

This comment has been minimized.

Show comment
Hide comment
@coolaj86

coolaj86 Sep 13, 2011

Contributor

Hmmm... try rm node_modules -rf; npm install jquery.

I just checked on the package.json and it is including jsdom.

You might also try npm install jsdom@0.1.2.

In the Ender.JS package (jQuery with a capital Q) I don't include the jsdom dep, but in the jquery package I do.

Contributor

coolaj86 commented Sep 13, 2011

Hmmm... try rm node_modules -rf; npm install jquery.

I just checked on the package.json and it is including jsdom.

You might also try npm install jsdom@0.1.2.

In the Ender.JS package (jQuery with a capital Q) I don't include the jsdom dep, but in the jquery package I do.

@wookiehangover

This comment has been minimized.

Show comment
Hide comment
@wookiehangover

wookiehangover Sep 13, 2011

ya, so it looks like someone bumped to 1.6.3 and published to npm... which isn't good since that version is completely broken. also, that jsdom version info from your comment is dead wrong-- the requirement for the working 1.6.2 package is "jsdom": ">=0.2.0"

are you the official maintainer for this?

ya, so it looks like someone bumped to 1.6.3 and published to npm... which isn't good since that version is completely broken. also, that jsdom version info from your comment is dead wrong-- the requirement for the working 1.6.2 package is "jsdom": ">=0.2.0"

are you the official maintainer for this?

@coolaj86

This comment has been minimized.

Show comment
Hide comment
@coolaj86

coolaj86 Sep 13, 2011

Contributor

I've played with it a little bit and pushed a new version.

In order to eliminate confusion between the Ender.JS and Node.JS versions I'm getting rid of jquery (lowercase) and requiring that you install jsdom and htmlparser sibling dependencies from now on rather than as children.

npm install jQuery jsdom htmlparser xmlhttprequest
Contributor

coolaj86 commented Sep 13, 2011

I've played with it a little bit and pushed a new version.

In order to eliminate confusion between the Ender.JS and Node.JS versions I'm getting rid of jquery (lowercase) and requiring that you install jsdom and htmlparser sibling dependencies from now on rather than as children.

npm install jQuery jsdom htmlparser xmlhttprequest
@coolaj86

This comment has been minimized.

Show comment
Hide comment
@coolaj86

coolaj86 Sep 13, 2011

Contributor

I'm the ad-hoc maintainer. I have no formal association with jQuery.

Sorry for the inconveniences of the 1.6.3 upgrade.

Contributor

coolaj86 commented Sep 13, 2011

I'm the ad-hoc maintainer. I have no formal association with jQuery.

Sorry for the inconveniences of the 1.6.3 upgrade.

@coolaj86 coolaj86 closed this Sep 13, 2011

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment