Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Missing dependencies #30

Closed
magnetik opened this Issue · 3 comments

2 participants

Baptiste Lafontaine James Morrin
Baptiste Lafontaine

Hi,

My config :

  • Windows x86
  • Python 2.7.3
  • node 0.6.19
  • npm 1.1.24

I've installed node-jquery via npm. Contextify install failed for whatever reason, but as it's optional, the install was successfully.
Complete install log : http://pastebin.com/21NB4xBf

When trying to use it : var $ = require('node-jquery');

> var $ = require('node-jquery');
Error: Cannot find module 'location'
    at Function._resolveFilename (module.js:337:11)
    at Function._load (module.js:279:25)
    at Module.require (module.js:359:17)
    at require (module.js:375:17)
    at create (C:\Users\magnetik\Documents\workspace\maniaplanet-ws-js-sdk\node_
modules\node-jquery\node_modules\jQuery\node-jquery.js:6:33)
    at C:\Users\magnetik\Documents\workspace\maniaplanet-ws-js-sdk\node_modules\
node-jquery\node_modules\jQuery\node-jquery.js:9065:18
    at Object.<anonymous> (C:\Users\magnetik\Documents\workspace\maniaplanet-ws-
js-sdk\node_modules\node-jquery\node_modules\jQuery\node-jquery.js:9067:1)
    at Module._compile (module.js:446:26)
    at Object..js (module.js:464:10)
    at Module.load (module.js:353:31)

So I guess that the module location is missing.

Don't hesitate to ask me for more information.

James Morrin

I was wondering if you could give it a shot again with node v0.8.1? I have had a hard time getting a windows machine to test on. Try the latest module on npm i just published some changes

Baptiste Lafontaine

Sure no problem !

Still the same problem.

Complete log : http://pastebin.com/1n0QtZjn

James Morrin

I think you might be trying to install the wrong module?

I see in the pastebin you have

npm install node-jquery

to install my module its

npm install jquery

I know its confusing but the npm module node-jquery is not my project.

looks like its pulling down an older version of my module.

npm http GET https://registry.npmjs.org/jQuery/1.6.3

I am at version 1.7.3

James Morrin treasonx closed this
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.