Permalink
Browse files

Remove JSON as a dependency, we let ActiveSupport worry about that.

  • Loading branch information...
sj26 committed Jun 10, 2011
1 parent 5ba5624 commit 0e8ac1c5a2fee916b834d030aa70fe84e037b199
Showing with 3 additions and 7 deletions.
  1. +0 −2 Gemfile.lock
  2. +0 −1 lib/mail_catcher/web.rb
  3. +3 −4 mailcatcher.gemspec
View
@@ -5,7 +5,6 @@ PATH
activesupport (~> 3.0)
eventmachine (~> 0.12)
haml (~> 3.1)
- json (~> 1.0)
mail (~> 2.3)
sinatra (~> 1.2)
skinny (~> 0.1)
@@ -32,7 +31,6 @@ GEM
fssm (0.2.7)
haml (3.1.1)
i18n (0.6.0)
- json (1.5.1)
mail (2.3.0)
i18n (>= 0.4.0)
mime-types (~> 1.16)
View
@@ -1,5 +1,4 @@
require 'sinatra'
-require 'json'
require 'pathname'
require 'skinny'
View
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
smtp://127.0.0.1:1025 instead of your default SMTP server,
then check out http://127.0.0.1:1080 to see the mail.
END
-
+
s.author = "Samuel Cochran"
s.email = "sj26@sj26.com"
s.homepage = "http://github.com/sj26/mailcatcher"
@@ -25,9 +25,9 @@ Gem::Specification.new do |s|
s.require_paths = ["lib"]
s.executables = ["mailcatcher", "catchmail"]
s.extra_rdoc_files = ["README.md", "LICENSE"]
-
+
s.required_ruby_version = '>= 1.8.7'
-
+
s.add_dependency "activesupport", "~> 3.0"
s.add_dependency "eventmachine", "~> 0.12"
s.add_dependency "mail", "~> 2.3"
@@ -36,7 +36,6 @@ Gem::Specification.new do |s|
s.add_dependency "skinny", "~> 0.1"
s.add_dependency "sinatra", "~> 1.2"
s.add_dependency "haml", "~> 3.1"
- s.add_dependency "json", "~> 1.0"
s.add_development_dependency "sass", "~> 3.1"
s.add_development_dependency "compass", "~> 0.11.1"

0 comments on commit 0e8ac1c

Please sign in to comment.