With this plugin its possible to add a default version to a project.
Ruby HTML
Pull request Compare This branch is 12 commits ahead, 1 commit behind benasher44:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
app/views/project_default_version
config
db/migrate
lib/redmine_default_version
test
.travis.yml
GPL.txt
README.md
default_version_1.png
default_version_2.PNG
init.rb

README.md

Redmine Default Version Plugin

Build Status Code Climate

This plugin enables you to specify a default version for a Redmine project.

The initial authors are Tony Marschall and benasher44.

Compatibility

This plugin version is compatible only with Redmine 2.1 and later.

Installation

  1. To install the plugin

    • Download the .ZIP archive, extract files and copy the plugin directory into #{REDMINE_ROOT}/plugins.

    Or

    • Change you current directory to your Redmine root directory:

        cd {REDMINE_ROOT}
      

      Copy the plugin from GitHub using the following commands:

        git clone https://github.com/Undev/redmine_default_version.git plugins/redmine_default_version
      
  2. Update the Gemfile.lock file by running the following commands:

      rm Gemfile.lock  
      bundle install
    
  3. This plugin requires a migration. Run the following command to upgrade your database (make a database backup before):

     bundle exec rake redmine:plugins:migrate RAILS_ENV=production
    
  4. Restart Redmine.

Now you should be able to see the plugin in Administration > Plugins.

Usage

If there are any project versions specified, the plugin adds the Default version field to the Information tab of the project settings.
default version

After you set a project version as default, this version will be automatically specified as the target version when you create a new issue for this project.
default version applied

Maintainers

Danil Tashkinov, github.com/nodecarter

License

This plugin is licensed under the GNU GPL v2.